I am trying to connect my Pi to an old tv, which only has composite input.

I have tried sdtv_mode in every mode (0 to 3) but it just gave me a flicking display.

When I was pluging in the HDMI cable, and then unplugging the composite video cable, to change the mode again, the signal became clear with no flickering.

After some experimenting, I found that if the composite cable was in the socket, but not clicked in, and the HDMI cable was plugged in to the TV and the Pi, the composite video would work... (I was on the AV channel on the TV)

Is there a way for me to fix this, so that I don't need the HDMI cable plugged in, as my old TV doesn't have a HDMI port, and I want to use that.

Thanks in advance, Tom

  • Which Pi? What cable are you using for composite?
    – Milliways
    May 1, 2016 at 10:25
  • It is the Pi 2b, and it is the composite with the three (yellow, red, and white jacks) on one end, and the single jack in the other end (sorry, I don't know the name)
    – Tom
    May 1, 2016 at 10:32
  • There are 4 different configurations for the cable. Some are equivalent if you ignore colours, but others are incompatible. You need a correct cable.
    – Milliways
    May 1, 2016 at 10:36
  • I think that it is compatible, as it displays an image with the HDMI plugged in...
    – Tom
    May 1, 2016 at 11:02
  • The reason you are getting interference is because the Gnd and Video connections are swapped. There is no analog sound when hdmi is enabled so no interference. I could Google the connections, but I am sure you could do the same. I suspect you will find an answer on this site.
    – Milliways
    May 1, 2016 at 12:00

1 Answer 1


The video wire goes to different pins on the 3.5 plug depending on which type of cable you have. I'm guessing it has nothing to do with HDMI. You moved the pins around in the 3.5mm socket by slightly plugging it in. Plug in a different color rca into the yellow video on your TV. I use white to yellow on my cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.