0

I need to "clone" my Raspberry's SD card, so I can send it to a friend. I need the project to work in any raspberry.

Seeing a lot of posts about how to do this, I decided to use Win32 Disk Imager. When I create the image and try to open the image to see if everything is okay, I get the following message: "The disk image file is corrupted".

I ignored that just to see if my raspberry worked with that SD card, but it didn't.

I was afraid that my original SD card was corrupted, but everything works fine with the original.

I ran the Disk Imager in compatibility mode with windows 7 (I have windows 10), but I get the same results.

Also, the original SD card is 8Gb and I am making the copy in a 16Gb card. I really don't care about the wasted space right now, I just want my project to work on any raspberry with the cloned SD card.

What am I doing wrong?

  • 2
    Possible duplicate of How do I backup my Raspberry Pi? – goobering May 1 '16 at 18:14
  • I know and I have read how to create the backup, but my question is that is not working for me and I don't know why. – Luz A May 1 '16 at 18:17
  • It's because you're trying to duplicate an 8GB image to a 16GB card. You need a card of equivalent size. – goobering May 1 '16 at 18:17
  • 1
    You should not have a problem copying an 8 GB image to a 16 GB card -- the normal images are smaller than any SD card actually used by anybody -- but not being a windows user, I can't say what's up with the (excessively high level) software used there. – goldilocks May 1 '16 at 18:29
  • The disk manager only writes a small partition so maybe you need to format the SD before you run the manager. – PaulF8080 May 1 '16 at 20:13
2

I'm going to assume that your real question is "I need to "clone" my Raspberry's SD card, so I can send it to a friend.", rather than difficulties with a specific way of doing it, ie. Win 32 Disk Imager and "What am I doing wrong?".

I found that Win32 Disk Imager was unreliable: I had 2 micro SD cards, both 16GB, same make and model and even bought at the same time, but the image of one was slightly bigger by a few bytes than from the other, and so it could not be restored to the slightly smaller card. Also, just because you have taken an image, you need to restore it in order to see that it works. I had also occasionally found that images would not restore, even onto a smaller card.

So instead I turned to rpi-clone, which I believe would be a solidly reliable answer for you. So I'm suggesting my answer to "What am I doing wrong?" is, "You're using an inferior method".

I've been using rpi-clone every day for a few weeks to clone my running RPi3 running Raspian Jessie. It takes about 10 minutes to clone to a second Micro SD card. I then switch off, take out both cards, store the original and boot using the clone. Hence I know that the backup works. I rotate 3 cards in this way, so that I always have a safe card. It works for me ;-)

The only thing I would say is that I don't believe you should be expecting a backup from one version of Raspberry Pi to work in a different version.

  • I just tried using the rpi-clone, and I got this error when I boot the raspberry: "Kernel Panic : VFS :Unable to mount root fs on unknown-block". I used my original 8Gb SD card and another 8Gb SD card. – Luz A May 2 '16 at 19:11
  • What command line did you use? For instance '-f' ? Could you provide more info? – Geoff May 2 '16 at 19:24
  • A quick Google of your error message makes me wonder: how are you powering your Pi? While the clone is running you should avoid using your Pi. What could be running on your Pi while the clone is running? – Geoff May 2 '16 at 19:27
  • I'm powering my Pi with a 5V adapter. In my project I'm using WebIOPi, could this be an issue? – Luz A May 2 '16 at 20:23
  • For the 10 minutes it will take to create a copy for your friend, and bearing in mind that other methods would involve taking the SD card out (and you will want to test it anyway), I suggest shutting down any processes you have started. – Geoff May 3 '16 at 6:40
1

It is normal for windows to say that the image is corrupted because the file system is EXT4 and FAT and windows is not used to having 2 partitions in the same image. To see the files in the image, use 7-zip (https://www.7-zip.org/a/7z1801.exe).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.