I have followed the tuto here : https://wiki.qt.io/RaspberryPi2EGLFS to cross-compile Qt 5.6 for my pi 2. But I did not used the git repo, I have downloaded the source tarball.

I checked by running the sample qopenglwidget.

I would like to use the WebEngine widget, but the module is not compiled. Does anyone has managed to have it work ? Thanks

The qmake output :

/home/dede/raspi/qt-everywhere-opensource-src-5.6.0/qtbase/bin/qmake -o Makefile qtwebengine.pro
Running configure tests
Checking for khr... yes
Checking for libcap... no
Checking for snappy... no
Checking for srtp... no
System zlib or minizip not found. Using Chromium's copies.
System libwebp or libwebpdemux not found. Using Chromium's copies.
System libevent not found. Using Chromium's copy.
System jsoncpp not found. Using Chromium's copy.
System opus not found. Using Chromium's copy.
System vpx >= 1.4 not found. Using Chromium's copy.
System libsrtp not found. Using Chromium's copy.
System snappy not found. Using Chromium's copy.
SSL............................... Using bundled BoringSSL
ICU............................... Using internal copy (Default, force system ICU with WEBENGINE_CONFIG += use_system_icu)
FFMPEG............................ Using internal copy (Default, force system FFMPEG with WEBENGINE_CONFIG += use_system_ffmpeg)
Proprietary codecs (H264, MP3).... Not enabled         (Default, enable with WEBENGINE_CONFIG += use_proprietary_codecs)

libcap development package appears to be missing
Unmet dependency: xcomposite
Unmet dependency: xcursor
Unmet dependency: xi
Unmet dependency: xrandr
Unmet dependency: xscrnsaver
Unmet dependency: xtst
QtWebEngine will not be built.

Is it that it seams that I have to install libs on the device and then rsync back to compiling machine ?


Actually, it's pretty simple. You'll need to go ahead and run a rather long apt-get:

sudo apt-get install libssl-dev libxcursor-dev libxcomposite-dev libxdamage-dev libxrandr-dev libfontconfig1-dev libxss-dev libxtst-dev libpci-dev libcap-dev libsrtp0-dev

And that's it! I'd suggest having some swap space before running the big make command. Also, this process takes 3 days and slows the system to a crawl. If you haven't done so, make sure you are using screen and get ready for the waiting game.

  • I will try this. I am cross-compiling on another computer, following the tutorial from my 1st message. – Dede May 5 '16 at 23:27
  • Hi, stil no luck. Only one package was missing (didn't remember which one). After this apt-get, I rerun the configure command, qmake -r, make and make install. No libqtweb* libraries available... – Dede May 11 '16 at 9:56

If you want my build includes it. But it is rc1. You don't need X11 libs if you intend to use eglfs.

  • Would be good to know the reason for the downvote... – Luca Carlon Aug 2 '16 at 6:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.