0

The problem is that I need to disable device tree to let SPI work successfully, but it results in malfunctioning built-in wifi and bluetooth.

uname -a
linux raspberrypi 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv71 GNU/Linux 

This is my /boot/config.txt

 hdmi_force_hotplug=1
 dtparam=spi=on
 device_tree=
  • Are you referring to Pi2 or Pi3? Pi2 doesn't have built-in WiFi and Bluetooth. – BillP3rd May 3 '16 at 5:18
  • Nobody else has reported needing to disable device tree to get a working SPI. Why do you? – joan May 3 '16 at 5:23
  • sorry, I mean pi3, but pi2 also have the problem. – user60627 May 3 '16 at 6:55
  • someone reported it. raspberrypi.org/forums/viewtopic.php?t=97314 – user60627 May 3 '16 at 6:57
  • That report is when the move was made to device tree - it says use device tree. You need to edit your question and include the content of /boot/config.txt so we can see you have correctly enabled SPI etc. – joan May 3 '16 at 8:20
0

Remove the line device_tree= from /boot/config.txt. That switches device tree off.

The SPI devices should then be available in /dev/spi* and a SPI module should be visible in lsmod.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.