1

I got a few new RPI3, with (Intenso) 8GB (class 10) SDHC cards and a original RPI PSU (5V / 2.1A).

Im running into a few very weird problems, after i installed RVM + Ruby i rebooted the system. Then i removed the X windows environment:

sudo apt-get remove --auto-remove --purge 'libx11-.*'

I then saw some errors (see screenshot). Is this some form of corruption? Any idea where it comes from? and more important how to prevent it?

enter image description here

Yesterday i also had similar issues with another card (bought 3 of these). I put it away thinking it would be a faulty card, but now im suspecting there is more going on.


Full image http://i.stack.imgur.com/bVVLO.png

4
  • There was no actual screenshot or evidence of one until I looked at the markup version, so I've inserted a (portion) of it above. – goldilocks May 3 '16 at 9:40
  • I think you should backup now. Run fsck from a Linux Live CD , while the SD card is inserted in a USB Card Reader. – flakeshake May 3 '16 at 10:36
  • @flakeshake, yeah but there is no data on it. Once its stable i make backups. – Roger May 3 '16 at 11:21
  • Running e2fsck is still a good idea, although Raspbian should do that by default at boot, you might as well double check it yourself. If there are corruptions it may fix them explicitly. – goldilocks May 3 '16 at 11:38
3

sudo apt-get remove --auto-remove --purge 'libx11-.*'

A debatably useful thing to do, since the complete X11 install is probably only a few hundred MB.

Interesting to note the reference to "dependency problems, but doing as you requested anyway". I'd say there's then a bug in apt/dpkg that shows up, but this is debatable too based the extent to which:

1) A tool should allow you to shoot you in your own foot. Or drill a hole in your own hand, or whatever, if you misuse it.

2) Appropriate warnings were provided.

3) This is really a consequence of having done something the wrong way, or just coincidence.

It appears you are still in a GUI so I presume this is from an SSH or other remote terminal.

Yesterday i also had similar issues

You don't explain what you mean by "similar". If you mean more or less the same, then obviously the result here is predictable. If that's all it is, I would not worry too much for now, but also don't do the same thing over and over again expecting a different result.

If you want a GUI-less install, start with the jessie-lite image (presuming you are using Raspbian). My preference is to actually start with the jessie-lite image (about 1.5 GB) and then install the GUI the way I want it; including a WM and various applications this adds another 1/2 GB, which is why I am pretty sure "x11-*" doesn't add up to much, depending on what also gets removed. I'm guessing --auto-remove --purge might do quite a bit and saved you somewhere around that, but before you take a wall down with a sledgehammer, make sure you understand what's in the wall. If you aren't sure, don't use a sledgehammer.

2
  • I'm running a server, no need or extra stuff (i need the space). Anyway, its not a clear thing since the corruption seems random. Yesterday (after reboot) i tried to run "gem install <any gem>" and it throws some garbage (when calling awk). Your approach, is exactly what i did to start. Bu since that run into yesterdays problems, today i tried the NOOB route. After i installed, i only did a "sync", followed by "sudo reboot" :-/ – Roger May 3 '16 at 11:19
  • But it's so satisfying to sledgehammer your way through a wall... – Jacobm001 May 3 '16 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.