4

How do I make the camera work? I installed v4l-utils, but v4l2-ctl is not working because /dev/video0 isn't there. And raspistill says that it needs the camera to be enabled via raspi-config, but there no raspi-config in repositories, so I need some way enable the camera.

6
  • 2
    If you choose to run some obscure distribution you are unlikely to find anyone on this site who uses it. Try asking on a support site for the distribution.
    – Milliways
    May 4, 2016 at 12:19
  • Also, when asking this sort of question, you are a lot more likely to get people to think about it if you say "I ran the same command under Rasbian and it did not work there either" (if it worked, the problem is obviously with your distribution, and you follow @milliways's suggestion).
    – JayEye
    May 4, 2016 at 17:25
  • Can't say I'd heard of alpine, but knowing a bit about the camera - whatever distro you use needs to boot with the camera's firmware blob which is usually /boot/start_x.elf as opposed to /boot/start.elf. However, I'd just downloaded the rpi image for alpine and it looks like it's only got the latter, so without some more work I'd say the camera simply isn't supported under that distro.
    – Dave Jones
    May 4, 2016 at 20:41
  • @Milliways I have searched the forum forum.alpinelinux.org/search/node/camera. It seems no one worked with camera. Alpine linux is great distro for raspberry, except camera support, unfortunately May 5, 2016 at 6:29
  • @DaveJones Tried that. I have added start_x=1 in config.txt, copy and pasted start_x.elf, as expected - not working May 5, 2016 at 6:34

3 Answers 3

3

Ok. After a little play with pi and alpine I have managed the answer:

  1. wget https://github.com/raspberrypi/firmware/blob/master/boot/start_x.elf
  2. wget https://github.com/raspberrypi/firmware/blob/master/boot/fixup_x.dat
  3. copy start_x.elf and fixup.dat to sdcard
  4. edit config.txt

    gpu_mem=256
    gpu_mem_256=64
    start_file=start_x.elf
    fixup_file=fixup_x.dat
    
  5. apk update
  6. apk add raspberrypi v4l-utils
  7. modprobe bcm2835-v4l2
  8. v4l2-ctl --overlay=1
3
  • I am on home-assistant alpine linux and cant find a config.txt file? Apr 28, 2018 at 8:39
  • @peterretief You should mount your SD card to your workstation. Then you can change config.txt with text editor. Apr 29, 2018 at 10:40
  • Thanks, I was using the Hass.io install rather than the general, I could ssh into the pi but apk was not linked at all Apr 29, 2018 at 11:24
1

I have got it working on a plain Alpine Linux 3.17.1 install on a Raspberry Pi zero w and 3b+ using the following steps (I assume that you have a working installation):

  1. Run setup-devd and answer with the options udev and y
  2. Add the follow to the usercfg.txt file
    dtoverlay=vc4-fkms-v3d
    camera_auto_detect=1
    
  3. Create /etc/modules-load.d/rpi-camera.conf with the following text
    bcm2835-v4l2
    # Change the resolution based the the sensor you have
    # For the sensor information goto: https://www.raspberrypi.com/documentation/accessories/camera.html#hardware-specification
    options bcm2835-v4l2 max_video_width=3240 max_video_height=2464
    
  4. Enable the community repo in /etc/apk/repositories
  5. Install libcamera libcamera-raspberrypi libcamera-tools
  6. Reboot
  7. Run cam -l to see the connected camera

To use the libcamera-apps from Raspberry Pi you either need to compile yourself or use a precompiled version from GitHub: https://github.com/wjtje/libcamera-apps-alpine

-1

I don't own a camera but the way to enable it is to run sudo raspi-config then go down to option 6 and select yes and I believe that this should enable it.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.