2

How do I make the camera work? I installed v4l-utils, but v4l2-ctl is not working because /dev/video0 isn't there. And raspistill says that it needs the camera to be enabled via raspi-config, but there no raspi-config in repositories, so I need some way enable the camera.

  • 2
    If you choose to run some obscure distribution you are unlikely to find anyone on this site who uses it. Try asking on a support site for the distribution. – Milliways May 4 '16 at 12:19
  • Also, when asking this sort of question, you are a lot more likely to get people to think about it if you say "I ran the same command under Rasbian and it did not work there either" (if it worked, the problem is obviously with your distribution, and you follow @milliways's suggestion). – JayEye May 4 '16 at 17:25
  • Can't say I'd heard of alpine, but knowing a bit about the camera - whatever distro you use needs to boot with the camera's firmware blob which is usually /boot/start_x.elf as opposed to /boot/start.elf. However, I'd just downloaded the rpi image for alpine and it looks like it's only got the latter, so without some more work I'd say the camera simply isn't supported under that distro. – Dave Jones May 4 '16 at 20:41
  • @Milliways I have searched the forum forum.alpinelinux.org/search/node/camera. It seems no one worked with camera. Alpine linux is great distro for raspberry, except camera support, unfortunately – Aibar Nurlanov May 5 '16 at 6:29
  • @DaveJones Tried that. I have added start_x=1 in config.txt, copy and pasted start_x.elf, as expected - not working – Aibar Nurlanov May 5 '16 at 6:34
2

Ok. After a little play with pi and alpine I have managed the answer:

  1. wget https://github.com/raspberrypi/firmware/blob/master/boot/start_x.elf
  2. wget https://github.com/raspberrypi/firmware/blob/master/boot/fixup_x.dat
  3. copy start_x.elf and fixup.dat to sdcard
  4. edit config.txt

    gpu_mem=256
    gpu_mem_256=64
    start_file=start_x.elf
    fixup_file=fixup_x.dat
    
  5. apk update
  6. apk add raspberrypi v4l-utils
  7. modprobe bcm2835-v4l2
  8. v4l2-ctl --overlay=1
  • I am on home-assistant alpine linux and cant find a config.txt file? – peterretief Apr 28 '18 at 8:39
  • @peterretief You should mount your SD card to your workstation. Then you can change config.txt with text editor. – Aibar Nurlanov Apr 29 '18 at 10:40
  • Thanks, I was using the Hass.io install rather than the general, I could ssh into the pi but apk was not linked at all – peterretief Apr 29 '18 at 11:24
0

I don't own a camera but the way to enable it is to run sudo raspi-config then go down to option 6 and select yes and I believe that this should enable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.