1

I have a small robot centered around the Raspberry pi 2 driving through a DFRobot Romeo (aka Arduino). When developing I have been drawing power from the USB connections on both the Arduino and Raspberry. When mobile the unit draws power from separate battery supplies for both the Raspberry, Arduino and the motors. This combination has worked very well. I recently upgraded the Raspberry to a pi 3 and now I am having a problem where any commands requiring GPIO output on the Raspberry will only work while I have the HDMI cable attached. This problem occurs regardless if the Raspberry is connected to the Raspberry power supply (I am using the new Raspberry 3 power supply) or to the battery pack.i.e. if I plug in the HDMI cable everything works fine - if I unplug the cable the GPIO output commands no longer work. It is as if the Raspberry is drawing power also through the HDMI port?

I am perplexed - any thoughts?

  • 1
    "any thoughts" Yes; try some paragraphs. No one can help without details of your connections, although as a first guess I would check ground connections. – Milliways May 8 '16 at 5:19
  • Thank you - your first guess was indeed correct. The problem was in the I2C ground link between the Pi and the Arduino. The connection was intermittent. Replacing the connection solved the problem. – David B May 9 '16 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.