4

EditPlus can connect to SFTP only with 3DES or AES128-CBC encryption. But Jessie doesn't seem to support it! I'm getting error that Could not agree encryption algorithm and few algorithms comma separated...

So i tried to add support by editing /etc/ssh/ssh_config...

Uncommented line:

Ciphers 3des,aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc

As you can see aes128-cbc is there.... but after sudo service sshd restart still the same... can't connect from EditPlus, and same list of supported ciphers... What's wrong? How do I enable it?

  • Try setting PasswordAuthentication yes in /etc/ssh/sshd_config (not ssh_config). – joan May 8 '16 at 12:37
  • 1
    Please don't do that. Update your EditPlus software to something up-to date, rather then downgrading ciphers supported by the server. These two are already partially broken. – Jakuje May 8 '16 at 12:57
  • @Jakuje can't... no new version, and I got used to EditPlus for years. – Flash Thunder May 9 '16 at 4:47
4

So i tried to add support by editing /etc/ssh/ssh_config

As per joan's comment, there is a difference between ssh_config and sshd_config:

  • ssh_config provides a default configuration for SSH clients connecting from this machine to another machine's ssh server, aka. sshd; here d is for daemon. Servers of all kinds usually but not necessarily operate in this mode.

  • sshd_config provides configuration for this machine's ssh server, sshd.

This can get a bit confusing because sometimes (I think this is the case on Raspbian), the init service which starts the ssh daemon (sshd) is just called ssh, which is also the name of the ssh client.

So, if you are trying to ssh into the pi, you are trying to connect to an sshd running there (technically there can be more than one, but this would be unusual). This includes making sftp connections. The default configuration for this server is /etc/ssh/sshd_config.

There are separate man pages, see man sshd_config and man ssh_config. These go into more detail with regard to the possible options in each file.


There's also a likely problem with your list of ciphers; if you look in man sshd_config under Ciphers you'll see a list, but since this is a hardcoded, stock manual page, it's also worth noting that you get an actual list of what's really available on the machine with ssh -Q cipher. E.g., I notice on a recent Raspbian Jessie that list has one additional entry for rijndael-cbc (which I think is probably an alternate implementation of one of the aes-cbc cipher). Anyway...

Ciphers 3des,aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
        ^^^^

I think one of these is not available. You might get more information about the error by running sudo tail -n 50 /var/log/syslog after trying to restart the server.

  • but when i copy that line with Ciphers from ssh_config to sshd_config, I am getting sshd error when restarting and until commenting it, the server won't run again, won't accept new connection (good that it keeps the old one alive). – Flash Thunder May 8 '16 at 12:55
  • I've added a speculation about this. – goldilocks May 8 '16 at 13:11
  • It actually worked :) Just used ciphers aes128-cbc and it works fine :) now it supports only one but putty works and editplus too, so its great :) thanx. – Flash Thunder May 8 '16 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.