When I try to boot my Raspberry Pi 3 with Windows IoT Core it remains on this screen forever:

it's stuck booting

I've tried 2 different builds now, 14322 and 14328. Also I tried via noobs and via the IoT dashboard from Microsoft. The device is connected to the internet via an ethernet cable. The OS is installed on a 32gb class 10 samsung evo micro sd card. Is this a known issue? How do I fix this?

  • Were you able to figure this out?
    – Fls'Zen
    Commented May 17, 2016 at 16:48
  • @Fls'Zen Sadly, no. I'm going to wait for a new IoT build to try again
    – RuteNL
    Commented May 18, 2016 at 22:59
  • I wound up getting a new 32GB samsung evo card (the one in the compatible hardware list) and installed 14342 on it before doing anything else to the card. It booted up in a couple minutes. I had it hooked up to a TV and did the setup process on-screen. The wifi didn't work until I rebooted it, but it seems to be working fine now. Hope you have better luck with it soon!
    – Fls'Zen
    Commented May 20, 2016 at 22:04
  • @Fls'Zen you should make your comment an answer so that the OP can determine if it's an incompatible hardware issue.
    – ShooShoSha
    Commented Mar 11, 2018 at 0:37

4 Answers 4


I had this problem too, it never got past that boot screen. It turned out it was a power supply problem. Pi 3 requires 2 A, and I had a 1.5 A micro USB adapter. When I switched to a 2 A adapter it worked as expected.


I had very similar problems - I found the length of time for the first boot increases with the size of the card (so I'd expect that a 32GB card could be 15 minutes or more).

You mention you've got it connected on ethernet - look at the list of devices on your Windows IoT Dashboard. If you can see it there then you know it's working at least. I sometimes find that the first boot finishes with an error - after 15 minutes I got a CRITICAL_PROCESS_DIED error, but it automatically rebooted after that, and after a shorter period of time it took me to the Windows IoT set up screen.

Windows IoT Dashboard image showing Raspberry Pi 3 on the network

I've posted about my experiences at the link below, but hopefully the information above is helpful to you given where you are in the installation process. https://jeremylindsayni.wordpress.com/2016/05/02/windows-10-iot-and-the-raspberry-pi-3-installation-failure-and-eventually-success/

I hope this helps.

  • Thanks for the answer. I still can't get it to work though, I let is go on booting for 70 minutes without succes. Also it doesn't show up on the dashboard. I'll just wait for a newer build of IoT, I can't think of anythink I haven't tried that could fix it, apart from buying a new sd card/raspberry..
    – RuteNL
    Commented May 18, 2016 at 22:59
  • That's a shame to hear that @RuteNL. If it helps, v14342 is available now on the Windows 10 IoT Core download page. It could be worth trying to flash the card with this, the try booting it with ethernet, and if that doesn't work, reboot and try with WiFi? Commented May 19, 2016 at 8:44

In my case it was a USB keyboard (dell keyboard with smart-card reader). Try connecting your peripheral devices after booting Win10 IoT.

  • Any idea as to what would cause this behavior? Also, please make an effort at using proper grammar in your answers.
    – Jacobm001
    Commented Dec 27, 2016 at 17:04

I got this problem as well, once. I was unable to open the Device Portal. Found out that faulty USB Power supply was the culprit.

Not the answer you're looking for? Browse other questions tagged or ask your own question.