0

Using the Raspberry Pi 3

My Linux

It's a Yocto image with Sato desktop

root@raspberrypi3:~# lsb_release -a
LSB Version:    core-4.1-noarch:core-4.1-arm
Distributor ID: poky
Description:    Poky (Yocto Project Reference Distro) 1.8.1
Release:    1.8.1
Codename:   fido

root@raspberrypi3:~# uname -a
Linux raspberrypi3 4.1.18 #1 SMP Thu Mar 17 10:26:07 CET 2016 armv7l GNU/Linux

What I have done so far

Created 10-monitors.conf file

root@raspberrypi3:/etc/X11/xorg.conf.d# ls -al
drwxr-xr-x    2 root     root          1024 Mar 19 04:59 .
drwxr-xr-x    7 root     root          1024 Oct 19 15:15 ..
-rw-r--r--    1 root     root          1099 Mar 17 08:31 10-evdev.conf
-rw-r--r--    1 root     root           330 Mar 19 04:59 10-monitors.conf

and added these

Section "Monitor"
    Identifier "Monitor0"
    Option "DPMS" "false"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime"     "0"
    Option "BlankTime"   "0"
EndSection

Inspired by this archlinux documentation

Will this work? How do I check that these were taken into effect?

Update

xset -q
xset:  unable to open display ""
4
  • It says right on the page you linked (xset -q) which implies you are having a problem, e.g., even though DPMS is disabled, you are still getting screen blanking. This would imply the cause is something else. If that's the case ask about your actual problem: meta.stackexchange.com/questions/66377/what-is-the-xy-problem/… If there is no problem, you already have the answer.
    – goldilocks
    May 12 '16 at 13:53
  • right, I had tried xset, although xset -q gives me an error. See update
    – zabumba
    May 12 '16 at 14:13
  • As a matter of fact, so far it looks like my solution worked. I am attempted to leave the post though. Might be useful to others... besides having fallen in a XY problem
    – zabumba
    May 12 '16 at 14:18
  • 1
    Exactly. The next question: "Lemme guess, you called xset from ssh, or otherwise outside X." It needs a display to refer to, by default the one you are using. If you aren't in a GUI, or there isn't one running period, you'll get unable to open display.
    – goldilocks
    May 12 '16 at 14:21
2

First, you need an output from xset -q. If you setup the Pie from ssh, add DISPLAY=:0 to every command that gives you unable to open display message:

DISPLAY=:0 xset -q

Then run

xset -dpms
xset s off
xset s noblank
xset s noexpose
xset s 0 0

or from ssh

DISPLAY=:0 xset -dpms
DISPLAY=:0 xset s off
DISPLAY=:0 xset s noblank
DISPLAY=:0 xset s noexpose
DISPLAY=:0 xset s 0 0

Keep your eye on Screen Saver and DPMS sections of xset -q output after each command. This way define what helps you to keep screen on.

Then add these commands to ~/.xinitrc where they will be executed every time the Xorg server starts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.