3

I'm trying to remote control some power outlets with my Raspberry Pi and I'm following the tutorial from this page. However, I have been unable to get any output from RF sniffer, I have 3 RF receiver/transmitter sets, and neither have worked. I've tried them on a Pi 2 model B and a Pi 3.

My terminal output

This is my terminal output after trying to reformat my Pi 3 and installing all the requirements.

My connections look as follows:

I have no idea how to draw these diagrams

I have no idea where to start with troubleshooting, since I am a programmer. I have checked the source code for RFSniffer and codesend, and it seems to connect to the correct pins. However, when I use Python to print the value of GPIO pin 27 it seems to give 0s and 1s intermittently.

I have read that this might mean that it registers no connection, or can it mean that there is some radio frequency being registered? I am unable to discern any difference in the output by eye when I press buttons on the remote or use codesend to try to send codes.

Is there any way for me to detect if it receives anything at all, or any other pointers as to what is wrong?

Thank you for reading.

3

You can use my piscope to check reception and transmission.

It is best to run piscope on a Linux machine networked to the Pi but it'll probably give acceptable performance when run directly on a Pi2 or Pi3.

piscope requires the pigpio library to be installed and to have the daemon running on the Pi (sudo pigpiod).

If your transmission uses Manchester Encoding (I expect it does) also have a look at http://abyz.me.uk/rpi/pigpio/examples.html#pdif2__433D to read and write fob codes.

There are a few other radio examples at http://abyz.me.uk/rpi/pigpio/examples.html#Index

| improve this answer | |
  • Thanks, I used PiScope, really useful tool, and was able to discern that it registers something. i.imgur.com/G94FdS9.png - I'll try to read up on your links and see if I can discern something myself, since RFSniffer is unable to pickup the codes. A lot of 1s and 0s all the time tho, unsure if that is indicative of a problem. – Robin May 13 '16 at 15:38
  • 1
    @Robin _433D may work better. See abyz.co.uk/videos/433MHz.webm which shows the situation with radio noise. The noise is immediately filtered out by _433D when it starts. – joan May 13 '16 at 16:09
  • Was unable to pick up from the remote using it. I also tried using a transmitter to transmit using _433D. When sending I see a clear correlation between the received waves and the transmitted ones (i.imgur.com/Cqm53tr.png) they are almost equal as far as I can see. However, it is unable to receive it. Maybe there is just to much interference here, weird though. Thanks for your help. – Robin May 13 '16 at 17:47
  • i.imgur.com/abPz1yz.png for a more zoomed in view, although I guess it doesn't help much with finding a solution to why it doesn't decode. I've been unable to find any information on the remote about which encoding it uses, but I guess it shoudl be able to read a manually transmitted one regardless. – Robin May 13 '16 at 17:58
0

The wire to GPIO17 is wrong conneted! You have to use the other pin of the receiver(the one which is free in the above picture on the left side).

Look at this page: https://hackernoon.com/diy-home-automation-fan-control-with-raspberry-pi-3-rf-transmitter-and-homebridge-59ad24845770

for the right wiring.

| improve this answer | |
  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Thanks! – Ghanima Jul 1 '18 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.