11

I was messing around with my raspberry pi and i managed to delete my toolbar. I managed to get everything back but the start button. How do I get it back??

10 Answers 10

10

This is not a direct answer to your question (hopefully you do get one) but a little bit of explanation that might help you to solve questions like this yourself. It seems to me a lot of people are coming to the pi with little or no previous linux experience and this would be a good idea.

Operating systems you may be more familiar with (eg, windows) have a unified graphical desktop that is always the same. There are no alternatives, so, eg, configuring the taskbar on one windows system is exactly the same on other.

Linux has no universal standard desktop environment. The Xorg server, which is universal, provides the basic facilities for a windowed GUI, but it has nothing to do with taskbars, titlebars, various other widgets etc. These are the domain of the window manager (WM) and/or the desktop environment (DE). There are lots of both available, the more popular DEs that might be familiar from ubuntu, fedora, and so on include GNOME, KDE, and XFCE.

Some of them are very ornate, with animated docks, transparent overlays, multiple desktops accessed by a crazy spinning cube, etc. but that stuff would just bog the pi down, so the pi specific distributions like raspbian sensibly opt by default for a more simple and resource light DE; in the case of raspbian it is LXDE.

You can in fact install and use a completely different DE (or WM) with raspbian, I am not sure what is all in the repo (it has FVWM, which is my preference, so I have not looked beyond that).

Anyway, LXDE has a wiki, which would be a good place to look for answers to questions like this. The "help and support" link there led me to the forum which appears active and I would bet already has a few savvy pi users skulking around ;)

9

Assuming you're using LXDE (wheezy/debian default Window Manager on RPi, as explained by goldilocks):

In your home directory (/home/pi) there is a directory called:

.config/lxpanel

(mind the dot before config, the full path is /home/pi/.config/lxpanel)

When you rename or remove this directory it will be re-created on the next startup of X, using the default values. That should bring everything back to the default situation. If you renamed this directory, you can put back the changes you actually want.

  • use "rm -rf directory_name" (without quotes) command to delete the directory – Tarik Sep 9 '16 at 20:13
2

I had this problem as well. I couldn't get back my original panel, but I managed to replicate it by simply right-clicking where it was, then going onto "Panel Settings", on "Geometry" click bottom left. Then go to "Panel Applets" and add Spacer, Menu, Desktop Numbers, and just experiment till you find the ones you want.

2

I also lost the Menu button on the tool bar and there is no easy way to get it back. I ended up using a terminal to copy the root panel to a shared area, then copied the panel to the user pi.

  1. Ctrl+Alt+F1 to get a terminal
  2. login as root
  3. cd ~/.config/lxpanel/LXDE-pi/panels
  4. cp panel /usr/share/lxpanel/
  5. reboot
  6. login as pi
  7. cp /usr/share/lxpanel/panel ~/.config/lxpanel/LXDE-pi/panels/
2

The logo you are looking for is at usr/share/raspberrypi-artwork/raspitr.png

Then right click the taskbar, panel preferences, panel applets, click the "menu" applet, click preferences, and enter the above path/filename for the icon location.

The icon changes back to the raspberry logo that was there originally.

0

When you right click on your panel you have the option to add applets. You simply need to add the menu and you will have it back.

But the icon for the menu will no longer have a picture of a raspberry, it will be a picture of a monitor/pc screen . Click on that and you will find all of the things you originally found on the default icon for menu.

0

I had tried a number of these suggestions but found a very simple solution. The TV I was using with hdmi had the overscan option as most TV's do. I didn't have to do anything to the raspberry. All I had to do was turn off overscan on the tv. It's easy to find out how to do this by playing with the tv menus or by going to the tv manual online. Now everything is working beautifully.

0

To get panel back I followed the below steps:

  1. Open terminal (if no shortcut for Terminal, No worry), then right click on "Trash" icon click on "Open in terminal"

  2. Run sudo su

  3. Create new user, like this:

    useradd test
    password <your password>
    
  4. Run pkill x

  5. Log in with test user. NOTE: once you have successfully logged in, reboot your Pi. After reboot the Pi will directly logged in as the "pi" user.

  6. Open your terminal again (as in step 1).

  7. Run cd .confing

  8. Run cp -R /home/test/.config/lxpanel .

NOTE: Just confirm once the owner of the "lxpanel"

following is expected result:

drwxr-xr-x 3 pi pi 4096 Dec 10 12:24 lxpanel

If not, then issue the follow command. Remember that you should use the "root" or "pi" user to do these steps:

  1. chown -R pi:pi lxpanel

  2. reboot

0

Unfortunately all of the above didn't work for me but what I did was even easier fixing lxpanel.

sudo su
apt-get purge lxpanel
apt-get autoclean
apt-get install lxpanel

Then restart Raspbian. After restart, go to Application Menu/Custormize look and feel to customize the Theme.

0
  1. Open Terminal : Press Ctrl + Alt + T

  2. Type in Terminal : rm -r ~/.config/lxpanel

  3. Type in Terminal : sudo service lightdm restart

  • Do I loose all my other settings on the lxpanel doing what you suggest? – Ingo Mar 20 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.