0

I have an issue with my initial boot. Indeed: I did it on a SD card and it seemed to have work as shown in the following picture:

boot

yet when I connect the Raspberry Pi with the card to the display screen with the HDMI wire I have a "no signal" message...

no signal

What went wrong?

My guess

I have read from Getting Started with the Raspberry Pi, on raspberrypi.org, that

the red LED marked PWR will light (except for the zero). The green LED marked OK (or ACK in later version) will blink in an irregular pattern to show whenever the Pi reads from the SD card.

Yet this never occured on my Raspberry...

Furthermore, I wonder whether it is because when writing an image (eg using 'DD') I have to ensure that the destination is the entire card and not a partition on it. Indeed the few writing operations on the command line where:

dd bs=1M if=2016-03-18-raspbian-jessie.img of=/dev/devmmcblkop&

dd bs=1M if=2016-03-18-raspbian-jessie.img of=/dev/sd1&

sudo dd bs=1M if=2016-03-18-raspbian-jessie.img of=/dev/sd1&

Which one of the following commands would be most appropriate for writing to the sd card if any?

What I did

I first seach for the sda to umount:

Having:

/dev/mmcblk0p1   60M     0   60M   0% /media/antoine/BOOT
/dev/mmcblk0p2  3,6G  3,2G  215M  94% /media/antoine/e6e7f776-11a4-4cd7-b4fd-c44ecdbfcf90

I umounted mmcblk0p2 and then tried again to give to the card the image.

:~$ sudo dd bs=1M if=2016-03-18-raspbian-jessie.img of=/dev/devmmcblkop
3847+0 records in
3847+0 records out
4033871872 bytes (4,0 GB) copied, 24,9113 s, 162 MB/s

Yet, once again the green light didn't blink and stayed on...

  • Is the HDMI cable connected (to the Pi and screen) before power on? – Steve Robillard May 16 '16 at 20:03
  • @SteveRobillard no, after having powered it – ThePassenger May 16 '16 at 20:04
  • Try connecting the HDMI cable then powering up. By default if not connected on powerup it uses the composite video. – Steve Robillard May 16 '16 at 20:07
  • @SteveRobillard no signal, still... – ThePassenger May 16 '16 at 20:08
  • have you tried using a different sd card? what files do you see when you open the scare up on a pc? – Mohammad Ali May 16 '16 at 20:46
0

so as stated in the comments you mention that after writing all zeros to the sd card using the command

sudo dd if=/dev/zero of=/dev/sdX bs=1k count=2048

You state that when trying to unmount your drive using the command

sudo umount /dev/sda1

that you get an error stating that the device is busy. With this information I believe that a process is attempting to write to your sd card in the background which is preventing you from unmounting it and is also quite possibly corrupting your sd card write. If you could please now ensure that it is the correct sd card that you are writing to by removing the sd card and using the command

sudo fdisk -l

Then by connecting the sd card and retuning the command listed above that will be the name of your sd card (note the name may change with disconnects). To forcefully unmount the drive you may use the following command listed below:

fuser -km /dev/sda2
  • k : Kill processes accessing the file.
  • m : Name specifies a file on a mounted file system or a block device that is mounted. In above example you are using /dev/sda2

Note: The command above may need to be run with sudo After your SD card has been successfully unmounted, use the command below to write your iso to your sd card.

dd bs=4M if=raspberrypi-img.iso of=/dev/sda2

bs=4M is optional. It stands for Block Size and is used to create larger blocks to write faster, if this does not work for you try bs=1M

  • Than you for considering my question. I did the command line you gave mequestion to show you them, and edited my , yet I'm nt sure of which sda is the one where the boot is set because of the * – ThePassenger May 17 '16 at 12:54
  • What part are you stuck on, because you do not need the boot column days in any of this sudo fdisk -l to see which dev drive it is. Just run the command, without the Ed card or adapter plugged in.then plug the sd card and and see which new dev drive shows up. If you can't figure it out on your own just share what it says before and after you connect the drive and I'll try and help you figure out which drive it is.OH you many also be looking at the boot * which is the boot hdd and not the sd card – Mohammad Ali May 17 '16 at 13:04
  • Please elaborate on which command you get stuck at and why – Mohammad Ali May 17 '16 at 13:04
  • I just uploaded what I did with your advises. I think the new dev drive is mmcblk0. – ThePassenger May 17 '16 at 13:24
  • You think what is? – Mohammad Ali May 17 '16 at 13:25
0

I had this very same problem. I found that it was 3 things. First, try using a different HDMI cable. Then, try following the procedures to re-install the image to your SD card. You can find that on www.raspberrypi.org, and type into the search bar how to install the raspbian image. And if that doesn't work, try changing out the PI unit. I have 3 RPI2B, and I found out that the one I wanted to use was quite abused and contributed to my issues. Trying any one of these combinations will end up with a satisfactory result, it's just time consuming. Your power source COULD be an issue too, but I doubt it. However one whom, is prudent would check on that as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.