1

I have this Raspberry Pi 3 B, and it seems that the on-board wi-fi is not showing at all.

I have downloaded and flashed a fresh image of raspbian, but that did not help. If I use an external USB wifi module, that works.

If I issue ifconfig there is no wifi adapter listed (unless I use the external one that I mentioned earlier.

I have also tried sudo apt-get... ... update ...upgrade ...dist-upgrade

I did not do anything configuration to use enable the wifi. I am not aware if there is anything such. I played around with wpa_supplicant, and added my network there like:

network={
ssid="mynetwork"
psk="***"
}

Any ideas?

Have a great day!

UPDATE: Here is my /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
  • 2
    All I can suggest is 1 - defective pi, or 2 - it's NOT a pi 3 – Jaromanda X May 17 '16 at 10:49
  • Do you tried rpi-update? – Huczu May 17 '16 at 13:49
  • Can you post the result of a cat /etc/network/interfaces command? It should contain (among other things) something like: allow-hotplug wlan0 iface wlan0 inet manual wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf (Ooooh, I've just realise mine has two. I must post a question as to why!) – KDM May 17 '16 at 18:26
  • Yes I did try rpi-update – ThomasMX May 18 '16 at 17:42
1

I had same problem. I downloaded RASPBIAN JESSIE May 2016 version, then it start working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.