3

I installed a clean Raspian from the newest NOOBS 1.9.1 setup on my Raspberry Pi B+. On boot the WLAN-Dongle is connected. I used the GUI to connect to my WPA2 protected Wireless Network, like described here. The Pi connects to the WLAN and shows me an IP-Address.

But now I cannot connect to the internet. loading www.google.com from the browser results in an error. I can also not connect via SSH from my PC using putty into my Pi. From the Pi I can also not ping my routers IP.

I looks like my Pi is totally disconnected although it is showing me an IP-Address an a WLAN-Connection.

I also tried to setup my WLAN via commandline like described here. But this also does not work.

How can I get access to the internet?

  • You have told us nothing. What did you actually do? Have you searched this site for similar issues? – Milliways May 18 '16 at 9:38
  • I tried to set up my WLAN like described in the documentation. I also read your question/anwer raspberrypi.stackexchange.com/questions/37920/… and many other turorials to setup via commandline, but nothing worked. If you are missing specific config files to help me, please tell me and I can provide them. – Simulant May 18 '16 at 9:46
  • I could ask you lots of questions guessing what you MAY have done,but only you know what you ACTUALLY did. – Milliways May 18 '16 at 9:54
  • I installed raspbian jessies from NOOBs 1.9.1, I clicked on the WiFi symbol in the right upper corner, I selected the WLAN of my router and entered the password in the dialog an pressed OK. That is all that I've done. IP-Address shows up but no Internet connection. – Simulant May 18 '16 at 10:15
  • Add the output of ip addr show and netstat -rn to your question. – ott-- May 18 '16 at 16:20
1

If what @ott said doesn't work, Try restarting your router and resetting your Internet modem. Just because you're connected to the network doesn't mean you're connected to the Internet. You should also re-download noobs, reinstall it, then try to connect to the Internet. I had a similar issue as you did, and a fresh installation of noobs fixed it for me. Using Ethernet connection, I would also try sudo apt-get update in the terminal. When that completes, use sudo apt-get dist-upgrade to ensure you've got the current updates. This could help the wireless issue you're having.

Edit: I ran by this just today. Give this a try. It's straight from adafruit.com.

If you find your module 'drops out' from time to time, you can fix it fairly easily with a command line fix (thanks perseus286!)

Create and edit a new file in /etc/modprobe.d/8192cu.conf

sudo nano /etc/modprobe.d/8192cu.conf

and paste the following in

# Disable power saving
options 8192cu rtw_power_mgnt=0 rtw_enusbss=1 rtw_ips_mode=1 

Then reboot with sudo reboot

  • after my third reinstall, it worked clean "out of the box". But I did the same steps. – Simulant May 19 '16 at 10:32
  • @Simulant, very good. I'm glad I was able to help. – BadgerTrucking May 19 '16 at 13:41
  • now after a reboot I am disconnected from the Internet again. I also cannot SSH over LAN into the Pi, but a connection to the WLAN is shown with an IP-Address... :-( – Simulant May 19 '16 at 17:51
  • @Simulant, HMMMMM... I've never run into these kinds of extensive problems. After a reinstall or 2 my Internet works. Perhaps you should not SSH over LAN, BUT just use the terminal from the Pi directly. – BadgerTrucking May 19 '16 at 19:12
  • @Simulant, try this. It looks promising...raspberrypi.org/forums/viewtopic.php?t=44044 – BadgerTrucking May 19 '16 at 19:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.