I just got my first Raspberry Pi 3 few days ago, however I've encountered some problem. (Please note that I am VERY.NOOB)

So when I've got a brand new Toshiba 64GB SD card hoping to do the job, properly formatted it, mounted the image (I've tried NOOB, Raspbian and MATE) and everything set up. The OS works completely fine until I reboot the Pi. Basically things wouldn't work after I turn it off. The boot sequence was halted at "Unable to mount root fs on unknown-block(179 2)".

I've followed some comments around the forums saying I should hold "SHIFT" and make changes, however the SHIFT doesn't do anything for me.

I'm using a MacBook Pro if that helps.

Thank you so much!

I tried the answer from the suggested solution, as I have mentioned, I can't get "Start the Raspberry holding the Shift key" to work, it is not reading my keyboard unless I'm in the GUI

  • 1
    Apart from the comment that you did everything "properly" you have told us nothing. What did you actually do? Have you searched this site for similar issues?
    – Milliways
    May 18 '16 at 9:27
  • Welcome to Raspberry Pi! Please take the tour and visit the helpcenter to see how things work here. We try to avoid duplicate questions if at all possible. If you find your question not answered in the linked duplicate, feel free to notify us and call for a reopen.
    – Ghanima
    May 18 '16 at 13:06
  • @Milliways So when I formatted the SD with the program SD association provided, formatted the SD into FAT32. As for Raspbian, I've followed the steps the site provided, sudo dd bs=1m if=image.img of=/dev/rdisk<disk# from diskutil>. Plug the disk in, power up. As for MATE, I did the same thing and mount the image on the card. Plug it in, power up. Both come back with same error while reboot. I followed the change of changing root=/dev/mmcblk0p2 to 0p6 and try to safe boot it by holding shift, pi wouldn't get any input from my keyboard, so I'm stuck. Thanks for your help!
    – DLeung
    May 19 '16 at 1:27
  • DO NOT put detail in Comments, edit into your answer. This may or may not be a duplicate. The supposed duplicate is about NOOBS and does not apply to Raspbian. Post the EXACT commands you used not "if=image.img" and "<disk#" and stick to a single distribution - I suggest Raspbian and tell us EXACTLY which version.
    – Milliways
    May 19 '16 at 2:35

According to the same issue here: https://raspberrypi.stackexchange.com/a/40855/42034

Edit your cmdline.txt on sdcard(boot partiotion) and replace root=/dev/mmcblk0p2 to root=/dev/mmcblk0p6

  • Thanks for your help @Huczu. I'm trying to follow the steps, changed the 2 to 6, encounter the 179, 6 problem. Now as I followed the steps, pressing "SHIFT" during boot does not do a thing. any idea how to enter safe mode?
    – DLeung
    May 19 '16 at 1:24
  • You can edit this file by mounting your sdcard in OSX. It's boot partition with FAT32 filesystem.
    – Huczu
    May 19 '16 at 7:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.