1

I set up Openwrt CHAOS CALMER on my Raspberry Pi 2. I plugged in a WiFi dongle that uses the RTL8192CU chipset (Link). I have been looking online and trying to install different packages to help correct the issue. When I plug in the dongle and boot Raspbian, it detects the dongle. After that, when I run ifconfig, the dongle comes up as wlan0.

But, when I look for wlan0 in Openwrt, it doesn't show up.

root@OpenWrt:~# wifi up
'radio2' is disabled
'radio2' is disabled
root@OpenWrt:~# wifi status
{
   "radio0": {
        "up": false,
        "pending": false,
        "autostart": false,
        "disabled": false,
        "config": {
            "channel": "36",
            "hwmode": "11a",
            "path": "virtual\/mac80211_hwsim\/hwsim0",
            "htmode": "VHT80"
        },
        "interfaces": [
            {
                "section": "@wifi-iface[0]",
                "config": {
                    "mode": "ap",
                    "ssid": "OpenWrt",
                    "encryption": "none",
                    "network": [
                        "lan"
                    ],
                    "mode": "ap"
                }
            }
        ]
    },
    "radio1": {
        "up": false,
        "pending": false,
        "autostart": false,
        "disabled": false,
        "config": {
            "channel": "36",
            "hwmode": "11a",
            "path": "virtual\/mac80211_hwsim\/hwsim1",
            "htmode": "VHT80"
        },
        "interfaces": [
            {
                "section": "@wifi-iface[1]",
                "config": {
                    "mode": "ap",
                    "ssid": "OpenWrt",
                    "encryption": "none",
                    "network": [
                        "lan"
                    ],
                    "mode": "ap"
                }
            }
        ]
    },
    "radio2": {
        "up": false,
        "pending": false,
        "autostart": true,
        "disabled": true,
        "config": {
            "channel": "11",
            "hwmode": "11g",
            "path": "platform\/bcm2708_usb\/usb1\/1-1\/1-1.4\/1-1.4:1.0",
            "htmode": "HT20",
            "disabled": true
        },
        "interfaces": [
            {
                "section": "@wifi-iface[2]",
                "config": {
                    "mode": "ap",
                    "ssid": "OpenWrt",
                    "encryption": "none",
                    "network": [
                        "lan"
                    ],
                    "mode": "ap"
                }
            }
        ]
    }
}

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr B8:27:EB:25:49:B8  
          inet addr:192.168.1.90  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe25:49b8/64 Scope:Link
          inet6 addr: fdad:28dc:e168::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22719 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14628 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2508036 (2.3 MiB)  TX bytes:3103130 (2.9 MiB)

eth0      Link encap:Ethernet  HWaddr B8:27:EB:25:49:B8  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27049 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14403 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3674587 (3.5 MiB)  TX bytes:3243136 (3.0 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:610 errors:0 dropped:0 overruns:0 frame:0
          TX packets:610 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:58143 (56.7 KiB)  TX bytes:58143 (56.7 KiB) 
  • I have installed these packages but it has not worked libnl libnl-tiny (depends on: libpthread) kmod-cfg80211 kmod-lib80211 kmod-mac80211 (depends on: kmod-crypto-core, kmod-crypto-arc4, kmod-crypto-aes, hostapd-common) kmod-mac80211-hwsim – greg5678 May 20 '16 at 1:10
  • I see that radio2 is disabled (disabled=true). Is that rigth? – migrc May 20 '16 at 6:32
  • Can you edit the /etc/confi/wireless file and set disabled = false? – migrc May 20 '16 at 7:29
  • I think you mean /etc/config/wireless. No I have not thank you for your suggestion! – greg5678 May 20 '16 at 11:53
  • Once you edit the file you should run the command wifi or also /etc/init.d/network restart (I should say that I worked mostly on Barrirer Breaker release and not so much over Caos Chalmer) – migrc May 20 '16 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.