2

(Moving this from apple.stackexchange.com)

I've connected my Pi Zero over USB to my OS X laptop and under Preferences -> Network it shows up as RNDIS/Ethernet Gadget, with a self assigned IP.

It says that RNDIS/Ethernet Gadget has a self-assigned IP address and will not be able to connect to the Internet.

I'd like it to be able to connect to the internet.

How does one enable this?

  • Have you attempted to enable DHCP on your pi? also what have you done so far in attempt to resolve the problem? – Mohammad Ali May 30 '16 at 3:24
2

System Preferences > Internet Sharing

First you have to select RNDIS/Ethernet Gadget then Internet Sharing

Sharing

  • You know what? I had "Share your connection from Ethernet" when I was using WiFi this entire time! Lol – Lolums May 21 '16 at 5:33
  • 1
    On my mac RNDIS/Ethernet Gadget won't show up. What can I do= – tmuecksch Mar 15 '17 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.