1

I just installed the latest Raspbian onto a new RP with seemingly no issues, then did apt-get update && apt-get upgrade as sudo.

The machine seems fine and quite happy on my network - I can ping it and ssh into it, and I can ping out of it and use http.

But I can't ssh out of it. My first hint was that I couldn't use ssh mode in github, but then I tried a server I own and I couldn't get to that either.

Looking at /var/logs I see no evidence of any relevant error. And ssh is enabled in raspi-config.

  • No progress whatsoever. I updated and upgraded everything. I tested the power supply, and then replaced it with a much beefier one. Really frustrating... – Tom Swirly May 28 '16 at 23:20
  • Please give us the output of: ssh yoursever -vvvv, replace yourserver with whatever server you've testet with. Add all options that are usualy need to connected to the server. Add -vvvv as it will give you (and us) more output what ssh is trying to do. Once you have the output: edit your question and add the information – MadMike Feb 12 at 11:52
0

did you enable ssh in raspi-config

sudo raspi-config, advances options, ssh, enable, reboot.

This might work.

  • Unfortunately, I did check that - and ssh comes turned on out of the box, I didn't have to turn it on. I'll add that to the original question. – Tom Swirly May 23 '16 at 0:49
0

Can you give us any error messages from ssh?

Also, even if you can ping it on the network and reach in via ssh, that doesn't mean it can reach outside. Are you using Network Address Translation, is it connected via Wireless LAN, is it connected via ethernet to a router, or is it connected directly to a PC of yours?

/etc/ssh/ssh_config is a relevant configuration file, by the way. Maybe some obvious errors in there.

Also, when trying to just get ssh working, I sometimes delete everything in ~/.ssh to get a clean slate.

  • Unfortunately, this was almost three years ago so that whole setup is long decommissioned. If I recall correctly, it turned out to be that there was a known bug involving my (common) wireless router and the RP3, so when I went to a wired connection, the problem ceased. – Tom Swirly Feb 13 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.