0

I've had problems with setting Raspbian Jessie as the default USB mic input and default on-board 3.5 mm jack out. I have a USB microphone and would like to use the Raspberry Pi jack audio out. I've read a lot about changing files like:

sudo nano /usr/share/alsa/alsa.conf 

but it didn't work for me. My ~/asoundrc file looks like this:

pcm.!default {
    type asym
    playback.pcm "hw:0,0"
    capture.pcm "hw:1,1"
}

ctl.!default {
    type hw
    card 0
}

Can someone help me?

  • I think that maybe the file in your home directory should be .asoundrc (with a preceding dot) – Jim Sep 5 '17 at 15:23
1

I had this trouble for weeks, and i eventually found it in the asoundrc but ive just typed this in on my new zero and its not there.

However i found an easier way :

menu preferences audio device settings sound card - then goto drop down menu and you should see your audio device . Select and make default.

Hope this helps.

  • This will not work. Setting a default will do exactly that, but for both Mic and Audio out. The question was how to set different cards for each. In fact setting a default seems to trigger the behaviour of the system to overwrite ~/.asoundrc on boot, then you will not be able to customise .asoundrc, so its about the worst thing you can do in this situation. – Lee Melbourne Aug 31 at 22:43
1

It works for me. I had a ~/.asoundrc file with following content:

pcm.!default {
    type asym
    playback.pcm "hw:0,0"
    capture.pcm "hw:1,0"
}
  • Perhaps you could elaborate a bit more than just "It works for me". – MatsK Jun 9 '18 at 20:58
  • Thanks, this helped me with my 3B+ more than this or this. In case it helps anyone, you can list playback devices with asound -l and recording devices with arecord -l (those are Ls). While troubleshooting, don't forget to check to see if anything has overwritten your changes with its own; that's happened to me at least once (probably when I opened the Raspbian audio dialog, though I wouldn't have hit save)... – A C Jul 15 '18 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.