1

I am using my Raspberry Pi as a radio transmitter. I'm using the Pi FM RDS program. It works fine for a few seconds, but then it just suddenly stops broadcasting the sound. The program is still running, but there is no more sound. It works fine again once I start the program again, but then it stops working again after a few seconds. I tried all radio frequencies in standard FM range, I tried unplugging the wires from GPIO pin 4, I tried adjusting the ppm and audio settings, I even tried a different program, still no success. Why is this happening?

I am using Raspberry Pi 2 (Yes, the program does work with RPi 2). I am running Raspbian Wheezy with a Waveshare Spotpear 3.5" Touchscreen TFT LCD and I am 75% sure GPIO pin 4 is not being used because I have tried it using RPi.GPIO in Python.

1

Yeah, I solved my own problem...For any PiFm related program, you should check if any kernel modules installed are causing the problem. For me, it was apparently some module related to temperature sensors that I did not even install. This solved my problem:

sudo rmmod w1-gpio

protected by Community Sep 19 '18 at 17:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.