I was configuring and running 2016-02-09-raspbian-jessie-lite on my Raspberry Pi 1 Model B+. Everything was fine and I used to shut it down using

sudo shutdown -h now

But there are circumstances where I also had to pull the plug. After that the Raspberry did not boot anymore. No LED blinked and I only got a black screen. So I took the SD card and checked it on my PC. Windows was only able to recognize 31 MB RAW partition: Recognized Partition

Now I am not able to delete or format the partition. I already tried to format/delete the card using:

  1. Windows build in tools (diskmgmt.msc, diskpart)
  2. Other windows tools like W32 disk Imager
  3. Linux tools like dd, fdisk

But none of them was able to format the card. All of them give errors different errors.


The format did not complete successfully.


No usable free extent could be found. It may be that there is insufficient free space to create a partition at the specified size and offset. Specify different size and offset values or don't specify either to create the maximum sized partition. It may be that the disk is partitioned using the MBR disk partitioning format and the disk contains either 4 primary partitions, (no more partitions may be created), or 3 primary partitions and one extended partition, (only logical drives may be created).

Gparted: Partition is not able to create a partition table at all.


dd: error writing '/dev/sdc': No space left on device 31+0 records in 30+0 records out 32096256 bytes (32 MB) copied, 3.6677 s, 8.8 MB/s

I am sure the card is broken after trying everything I can think of. My questions are now:

  1. Does anyone else have further possibilities to restore the card?
  2. Does it happen to other people with their raspberry?

I assume mine has some hardware issues. Especially after it happened to two cards already. I can understand that the filesystem may break on a SD card when pulling the plug, but not breaking it completely!

  • Have you tired mini-tool partition wizard?
    – Darth Vader
    Commented May 26, 2016 at 12:12
  • I tried it and the result is funny. All tests are green and successful. Creating partition is "successful" (pop up with a success message), but gone after reloading the disk. And it also shows 31 MB of space on the disk.
    – iwan.z
    Commented May 26, 2016 at 18:08
  • So you have created changes and more importantly applied them? This makes the changes to the SD cards partitions permanent.
    – Darth Vader
    Commented May 26, 2016 at 18:10
  • yes, exactly. I tried the same on an other SD card (to verify that I am not that stupid) and it worked there. So no luck :(
    – iwan.z
    Commented May 26, 2016 at 18:18

5 Answers 5


I doubt it's your pi. It seems to me that you're just trying to do something with the partitions in diskpart. So instead, use diskpart and do this: Type: List disk

Then type: Select disk (use whatever disk number is your SD card)

Then type: Clean

This process will completely erase EVERYTHING about the SD card.

THEN format the card by using the computer management tool. Right click the disk you want to format (in this case your SD card). Select format. Format the SD card as FAT or FAT32.

This should take care of your problem. This did for me when I had the same problem as you.


I assume mine has some hardware issues. Especially after it happened to two cards already.

This may eliminate Milliway's hypothesis, particularly if they are different brand/models of card and/or you want to go for a third one.

Although I believe (as someone who at least glances at almost every question here everyday) it has become much less common in past year or so (and may or may not have had a peak season because of the this issue), we have gotten enough reports from people who seem confident, and manage to convincingly convey reasons for that confidence,1 to say that very likely not every pi makes it to the shelf free of defects.

I'm explaining this because what you are describing, especially the "permanently damaged" part, is not normal behavior. There is actually very little chance of filesystem corruption if you pull the plug on a pi which has been idle, SD card I/O wise, for 15-20 seconds (to ensure the kernel, if still capable, has synced the disk cache). Beware that "very little" here may equate to "only occasionally" if you make a habit of this, so don't.

Most pi users I am sure have occasional power outages, etc., and never have corruption problems. I haven't after ~3.5 years, and 4 pis (all still fine) that I play with regularly, at least one of which is on all the time, etc. In fact I had to pull the plug on one last night.

Anyway, I don't know what the possibility for a machine to damage a card are, but obviously at some point, even if cards have some degree of surge protection built in (which without having investigated, I'd assume they don't, and rely on the reader/machine for proper regulation), you could put enough volts/amps through the machine to damage quite a few things permanently including any attached SD card. I'd postulate there's then a chance for a machine with 5V potential, if defective, to damage cards.

So if the pi is new and it really has done this a few times in a row, you may want to consider contacting the distributor and asking them for an exchange.

1. Most reports of filesystem corruption do not fall into this category in my opinion, but there has been more than a few that, particularly after a bit of prodding for information, convinced me.

  • I think you are absolutely right the Pi seems to have a defect. Both SD cards were from Sandisk. One was 32 GB (ultra something) and the other one was 16 GB and both died. The Pi is a bit older (around 3 years I think). So I will just throw that one away and buy a new one.
    – iwan.z
    Commented May 26, 2016 at 18:10
  • Before you do: If the cards aren't new they definitely have a limited lifespan (whereas I think a pi in theory does not). Would be kind of a weird coincidence, of course, and in trying a new card you are gambling whatever that is worth.
    – goldilocks
    Commented May 26, 2016 at 18:59

I had a similar issue some time ago with a brand new SD Card, which failed after one use. The Card was replaced under warranty.

  • I would agree if it happens only once. But it happened to two different cards in the same device with the same result. I am pretty sure it is the Pi in this case.
    – iwan.z
    Commented May 26, 2016 at 18:24

I have same problem with an 16GB SD card of Samsung. After trying all the software solutions available on internet i moved onto hardware issues and figured out there is very small crack on the SD card that can not be observed easily. i observed it with flashlight.

Image of SD Card

Its cause was the SD slot of raspberry pi. I put the PI in my backpack where he received some kind of force on it that resulted in crack. After this crack the SD Card shows on the windows disk Management as 13MB RAW Disk and noting else.

  • Was getting nowhere with a 16GB SanDisk micro SD card, macOS was only seeing 32.1MB (tiny). Just noticed a crack in the label face similar to the one in your image. I suspect I broke it when pulling the RPi out of its case (after failing to get the card out with my finger nails).
    – Peter Cock
    Commented Jun 10, 2020 at 16:00

These cards are overheating, causing fractures. I have had two of the same Sandisk ultra plus 32gb cards that overheated and fractured, like many of the cards above.

Not the answer you're looking for? Browse other questions tagged or ask your own question.