3

I am trying to set up my raspberry pi 3 with two wireless interfaces. The first connecting to my home network. The second would act as a wireless access point which would allow other mobile devices to connect to the pi. I am currently having issues with the even getting the second interface to appear in ifconfig currently my /etc/network/interfaces contains the following

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I expected that I should be able to just copy and modify wlan0 block to look like.

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

and at least be able to see ifconfig show wlan1 after restarting the pi.

1

What you have should work (although I haven't tested on a Pi3), BUT won't do what you expect.

You don't actually say what OS you are using, but both wlan0 & wlan1 should both be in /etc/network/interfaces and both will connect to your router, unless you have fiddled with network settings.

If you want to setup an Access Point you need to configure one NOT to get automatic settings from your router, using dedicated Access Point software and bridge.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.