0

I am running a Raspberry Pi 3 with the latest version on Raspian Jessie

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"

I have just bought the following device: Raspberry PI 2.8 TFT Add-On V1.0

I have the one that doesn't fit on the Raspberry Pi 3 - however I have been told it shouldn't be an issue.

I have followed the following instructions: 1. I ran raspi-config - and I was unable to expand the filesystem:

│ Your partition layout is not currently supported by this │
│ tool. You are probably using NOOBS, in which case your │
│ root filesystem is already expanded anyway.

I was also unable to find anything about a device tree under advanced options, but I enabled SPI even if it wasn't required

  1. I added the following to the end of /boot/config.txt dtoverlay=hy28b,rotate=90
  2. I ran this: sudo dpkg-reconfigure console-setup and set it up accordingly
  3. I modified /boot/cmdline.txt so that it looks as follows: dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait fbcon=map:10

The screen is always just white when I reboot. It never displays anything more. Please help!

0

So for the most part I had the wrong device. I needed to follow the blog post here: RASPBERRY PI 2.8 TFT ADD-ON V1.1 TOUCH FUNCTION REALIZING

Mainly what I did was:

  • sudo apt-get update
  • sudo apt-get install xinput evtest tslib libts-bin
  • Created a file called /usr/share/X11/xorg.conf.d/99-fbdev.conf with the contents:
Section "Device"  
    Identifier "itdb28"
    Driver "fbdev"
    Option "fbdev" "/dev/fb1"
EndSection

Then run:

sudo modprobe fbtft_device name=itdb28 gpios=reset:14,dc:2,wr:3,cs:8,db00:17,db01:18,db02:27,db03:22,db04:23,db05:24,db06:25,db07:4 rotate=90 fps=50 
sudo startx &

As for the touch, I am not sure how to get that to work yet...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.