5

I have a Pi camera V2.1 and a Pi Zero V1.3 with an adapter cable for the camera. I made sure to connect it correctly on both sides, metallic connections towards the green PCB. I have done a sudo apt-get update and a sudo apt-get upgrade and I have enabled the camera via sudo raspi-config and rebooted. When I run the command raspistill -o image.jpg I get the following error:

mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not enabled in this build. Try running "sudo raspi-config" and ensure that "camera" has been enabled

Telling me that the camera is not enabled.

I have seen that this error also occurs when no camera is connected. So, I connected the camera to my Pi 3 to see if it was broken, but it worked fine on there.

Is there any reason I am seeing this error? What do I need to do to fix it?

EDIT:

I very monotonously checked every connection on the camera's cable with a multimeter and they all were fine.

  • 1
    I didn't even know the Pi Zero had a new version that could get a camera. Now, I must have one. lol As far as your question, my guess is that the software is broke and they haven't fixed it yet. That's kind of what the error is telling you. Is it officially supported in software yet? – YetAnotherRandomUser May 29 '16 at 17:09
  • @allanonmage I've seen videos of people using it, so I assume so. I'm imaging a brand new sd card with the May version of Raspbian Jessie Lite, if that doesn't work, I'll try full Raspbian Jessie. – Patrick Cook May 29 '16 at 17:10
  • 1
    @allanonmage The newest Raspbian Jessie Lite made it work. Guess I can't use sudo apt-get update if I want to truly update the OS. – Patrick Cook May 29 '16 at 20:12
  • Lol yup. Totally different. – YetAnotherRandomUser May 29 '16 at 21:05
  • 1
    @PatrickCook You should post your answer as an "Answer", so people can find it easily. – tlhIngan Jun 25 '16 at 21:13
1

Try using the following commands:

Sudo apt-get update

Sudo apt-get upgrade

And if that does not work, I would recommend that you reimage your SD card.

1

I needed to install the newest Raspbian for it to work, both Jessie and Jessie Lite worked. But I had to format the card from scratch. apt-get update would not work.

1

Use rpi-update to update the 'firmware' without having to reimage the SD card.

1

I was getting the same error using the Octopi image. Running

    sudo apt-get dist-upgrade

worked for me on my pi zero. I know this question is a bit old, but I just thought I should mention it since it is easier than re-imaging the SD card if apt-get update or rpi-update does not work.

0

I had the same problem, it was caused by the camera being open in a python application. Closing my python application solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.