0

I'm not able to install Scipy on my Raspberry Pi Model B.

My current setup is:

  • Raspberry Pi model B running Raspbian Jessie and 16gb SD card.
  • OpenCV 3.1.0 installed on the raspberry pi using this tutorial.
  • Python 2.7.9 installed on the RPi

I tried using pip install Scipy and have also tried pip install scikit-image without any luck. Here is the screenshot of the error I got:

enter image description here

The main warning that seems to get repeated is:

warning "Using deprecated NumPy API, disable it by"

I have installed matplotlib and numpy successfully on my Raspberry Pi, it only fails while installing Scipy.

I then tried sudo apt-get install python-scipy and it installed Scipy version 0.14.0-2 successfully, however I am unable to import the module. I get the following error:

No module named scipy

Is there a fix for this? I'm not sure why Scipy is repeatedly failing to download.

  • please do not post screenshots. Redirect the relevant output to a file and post the contents of the file, properly formatted. – JayEye May 29 '16 at 22:50
  • If you have time to reinstall OpenCV, follow up my tutorial. I don't use Virtual Environment for installing OpenCV. Just change the version to be 3.1.0 as yours. – Tes3awy Aug 3 '16 at 17:02
2

It seems as if your problem is that you are running old packages and modules please update your pi using the following commands:

sudo apt-get update

sudo apt-get upgrade

and tell me if it solves your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.