2

Since installing the latest build of Raspbian onto my Rasberry Pi 3, I've been getting the following error:

setterm: terminal xterm-256color does not support --blank setterm: cannot (un)set powersave mode: Inappropriate ioctl for device

I've found a couple of posts on this topic, but none have offered a solution to the issue. I've tried the solution listed here e.g. adding consoleBlank=0 to /boot/cmdline.txt, but to no avail. Also suggested here.

Within this thread the above solution is mentioned but also that this issue could be a general bug with latest version of Raspbian (or Debian).

Is there any thing left to try? Is this indeed a bug?

1

An xterm cannot possibly have support for power saving; you can't power-save part of the screen and have the rest be on!

  • Makes sense, but where can I change/find these settings? This warning appears immediately following a fresh installation of Raspbian. – frederickk May 31 '16 at 0:07
  • where does it appear? The boot console gets TERM=linux on Raspbian by default, as do all the vtys. Are you setting TERM in your .bashrc (or equivalent)? – JayEye May 31 '16 at 0:59
  • The above settermsimply appears as the first lines in the command line (desktop and cli mode). I haven't set anything as everything is default. After attempting the solutions listed in my initial post, I re-installed Raspbian just to make sure it wasn't something I had fiddled with. I came across this post which mentions that mucking with .bashrc isn't a proper solution (granted the article isn't Pi specific). – frederickk May 31 '16 at 3:32
  • what is running it? something must be setting your TERM variable to the value you are getting. I just tried a virgin jessie installation (the may 10 release) and i don't see anything like that. – JayEye May 31 '16 at 5:52
  • Sorry for the delay. After another reinstall, I think I've tracked the source of the error. It's not an issue with Jessie, but rather the error appears after installing openframe. The install for openframe appends the following BLANK_TIME=0 and POWERDOWN_TIME=0 to /etc/kbd/config – frederickk Jun 12 '16 at 2:39
0

Not Raspberry Pi specific but I ended up here from Googling setterm: terminal xterm-256color does not support --blank

If you are ssh'd into your machine and trying to run the setterm command, you will need to physically be in front of the machine in a tty for the command to work. Hope this helps someone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.