I am using a webcam with built in microphone for my raspbery pi and i am trying to make my raspberry to work with vocie recognition. When i run


I get this:

Bus 001 Device 005: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

My webcam is recognized. Now, how do i check if my mic is recognized ?

I ran arecord -l but i got nothing listed.

Can someone give me an advice ?

4 Answers 4


I know this question is old, but in case someone stumbles upon this sort of issue (as I did):

This could possibly be an access rights problem. If running the command as root sudo arecord -l finds a card, then check if you (the respective user) are a member of the group audio. If you are not a member of the group audio, then add yourself to the group via sudo adduser <your_username> audio.

If none of this states true, you have to investigate deeper.


i can use the webcam microphone in some applications, but when I try to use the jitsi-meet, then chromium doesn't understand webcam microphone. (It can use the webcam as camera without problem).


I'm trying to use a pi as an internal intercom and wanted to start chromium in kiosk mode connecting to a jitsi conference. Unfortunately only the camera worked despite giving mic permissions.

sudo arecord -l showed the camera as an USB Audio device but no luck getting it to work in chromium.

I had to go into chrome://settings/content/microphone and select the 'USB Audio-Hardware device with all software conversations' from the dropdown menu. Default nor any of the other selections worked.

After a refresh of the jitsi page the mic started working.

I tested it on a Raspberry 3b with the latest 'Raspbian Buster Desktop' image with a Logitech hd webcam c310.

  • This worked for me with a Pi 4 in 2021 Mar 31, 2021 at 20:46

try: sudo arecord -l

On my RaspberryPI 3 I get:

**** List of CAPTURE Hardware Devices ****
card 1: C920 [HD Pro Webcam C920], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.