I am using a raspberry pi 3 with eth0 connected to a router with no internet and wlan0 connected to a router with internet access. i want both the interfaces up. but right now only eth0 is up. I followed this link

Setting up WiFi and Ethernet

as suggested my interfaces file looks like this

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.97
netmask 255.255.255.0

auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
   address 192.168.1.115
   netmask 255.255.255.0
   broadcast 192.168.1.255
   gateway 192.168.1.1
   iface default inet dhcp

And /etc/default/ifplugd looks like this

INTERFACES="eth0"
HOTPLUG_INTERFACES="eth0"
ARGS="-q -f -u0 -d10 -w -I"
SUSPEND_ACTION="stop"

After changing this I also entered these commands

sudo /etc/default/ifplugd eth0 --kill
sudo ifup wlan0

This was working for Raspberry pi 1 but it is not working for Raspberry pi 3. Please help

  • If you left the "interfaces" file as it was (rather than following an obsolete link) it would work. See How do I set up networking/WiFi/Static IP for default settings. – Milliways May 30 '16 at 12:59
  • I had back up of the original interfaces file. i rolled back, but did not help. it is associated with the wifi router, but not able to ping google.com. On the other side Raspberry pi can ping all the devices on the ethernet interface. if i remove the ethernet, it can ping google.com. i want both the interfaces up at the same time – Sundeep Srinivasan May 30 '16 at 13:29
  • If you have restored files include current contents in question and describe your network in detail e.g. do the routers have DHCP and list output of ifconfig. – Milliways May 31 '16 at 0:31
  • Oh the issue was resolved. i just noticed that Raspberry pi was able to ping 8.8.8.8 but not google.com. so i realized it was address resolution issue and added my DNS Server address to /etc/resolve.conf thanks by the way @miliways – Sundeep Srinivasan May 31 '16 at 13:40

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.