2

When I plug in my USB drive, it appears to be auto-mounted in /media/pi/Mega 3.

I'd like to mount it in a different place.

I tried doing that with the command sudo mount -t ntfs-3g -o uid=1001,umask=007 /dev/sda1 /media/USBHDD1/

This gives me the error message

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.

When I run fuser /dev/sda1, it gives me no output.

If I umount it I can then mount it wherever I want, but as soon as I reboot, it's back to being mounted in the original place.

What is causing it to be auto-mounted, and how can I configure it?

2
  • I believe this is a feature of the desktop environment, which on Raspbian is LXDE. I've never used it and never been plagued (or privileged...) with automounting issues, but a quick search for "lxde automount" implies that more specifically it's LXDE's file manager, PCManFM, that's responsible. This is pretty old, but it may still be the same and it is worth looking through PCManFM's preferences or whatever to see what you can find.
    – goldilocks
    Sep 19, 2016 at 22:17
  • If that leads you to a solution please leave an answer of your own explaining it, I am sure you are not the only one to find this more of a hassle than a benefit.
    – goldilocks
    Sep 19, 2016 at 22:17

2 Answers 2

1

Recommend using sudo apt-get install usbmount

usbmount automatically mounts usb storage and can be configured to at desired locations by editing the /etc/usbmount/usbmount.conf

0

It is being mounted to the same place because that's the default. I myself don't have a clear cut suggestion for you. However, not to be mean or anything, but what's the reasoning as to why you wish to change the mounting location? If it is recognizing the device, I'd call that a win. I can't even get my PI to recognize my HDD. I would just leave it like it is. At least you know where it's mounting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.