6

I want to auto login to the terminal after boot (Jessie).

I tried the instructions here (http://elinux.org/RPi_Debian_Auto_Login), but it didn't work. I think the problem is the new systemd init structure in Jessie.

So, is there any method to auto login to the terminal in Jessie !?

21

Enter the command sudo raspi-config. Scroll down to Boot Options and select Console Autologin. Then exit the configuration menu and reboot.

  • @Hack-R this answer is over a year old. When I wrote it, there was no intermediate screen. Feel free to edit it and add the new menu. – Patrick Cook Feb 12 '18 at 20:41
  • This action should be used with prudence (if you have removed the pi user probably you will have issues like this: raspberrypi.stackexchange.com/questions/64189/…) – garciparedes Mar 17 '18 at 8:33
2

I found this, the only thing that worked for me.

Automatic Login for LightDM

Open the terminal and make first a backup of the file we are going to edit:

su - 
gedit /etc/lightdm/lightdm.gedit /etc/lightdm/lightdm.conf.back

Edit now this file:

gedit /etc/lightdm/lightdm.conf

or

nano /etc/lightdm/lightdm.conf

Uncomment these two lines:

autologin-user=USERNAME
autologin-user-timeout=0

Replace USERNAME with your own username. Save the file and exit. Run now this command so that changes are taken into effect:

dpkg-reconfigure lightdm 
2

Look at this question, it shows how to enable and disable autologin, both for the GUI and the command-line; raspi-config also does it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.