1

I have a raspberry pi 3 running Jessie with shairport-sync installed. I have a CM-108 USB sound card connected. I have spent several days trying to figure out why I couldn't get sound out of the sound card. I made all the suggested changes to all the configuration files, etc to ensure that the sound card is the default. I managed to get sound out of the soundcard at most three times in two days. However, if I paused the music (played from my iphone), I couldn't get it to start again. If I restarted the shairport-sync service, or rebooted the Pi, the music wouldn't start.

After a couple of days of reading things on the internet, I read that the problem may be network-related. So, I connected the Pi to ethernet to my router. I could hear the music playing straight away. I restarted the service and rebooted and I the music would play every time. Repeat, everything works exactly as it should if it is connected to the ethernet cable. If I disconnect the cable, the music will continue to play for a until I restart the Pi.

I read a couple of things about disabling the power management on the wifi which I did. But it still won't work.

I thought it might be something to do with the drift, or resynchronisation settings, but I don't really understand what to do there.

How can I get shairport-sync to play from wifi from boot-up without first connecting to an ethernet cable?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.