1

I'm trying to install a dashboard functionality on a raspberry pi, the problem is that I installed the Lite version of Raspbian Jessie so I had to install new packages to do what I want and now I can't install anything because of this

    Do you want to continue? [Y/n] y
    Illegal instruction
    Setting up tzdata (2016d-0+deb8u1) ...
    dpkg: error processing package tzdata (--configure):
     subprocess installed post-installation script was killed by signal (Illegal instruction)
    Errors were encountered while processing:
     tzdata
    E: Sub-process /usr/bin/dpkg returned an error code (1)

This is what I get every time now. What can I do? Do I have to reinstall?

Edit: When I type sudo apt-get update I get this

Reading package lists... Done
W: GPG error: http://ftp.fr.debian.org jessie-proposed-updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
W: GPG error: http://security.debian.org jessie/updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
W: GPG error: http://ftp.fr.debian.org jessie Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY CBF8D6FD518E17E1

And for sudo apt-get upgrade I get

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
  libjpeg8
Use 'apt-get autoremove' to remove it.
Done
The following packages will be upgraded:
  aptitude bash bzip2 dash diffutils dmsetup dpkg dpkg-dev findutils initramfs-tools iptables iputils-ping
  libaudit1 libbz2-1.0 libcloog-isl4 libcroco3 libdevmapper1.02.1 libdpkg-perl libffi6 libfontenc1 libglc0
  libgphoto2-6 libgphoto2-port10 libgpm2 libice6 libkeyutils1 liblcms2-2 libldap-2.4-2 liblzma5
  libmysqlclient18 libncurses5 libncursesw5 libnewt0.52 libpam-modules libpam-modules-bin libpam0g
  libpciaccess0 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libproxy1 libreadline6
  libsdl-image1.2 libsemanage1 libsm6 libssl1.0.0 libtinfo5 libustr-1.0-1 libwebp5 libxapian22 libxaw7
  libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shape0 libxcb-shm0
  libxcb-sync1 libxcb-xfixes0 libxcb1 libxcursor1 libxdamage1 libxdmcp6 libxfixes3 libxi6 libxinerama1
  libxpm4 libxrandr2 libxrender1 libxslt1.1 libxt6 libxtables10 libxtst6 libxv1 libxxf86vm1 linux-libc-dev
  logrotate mysql-client-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5 ncurses-bin
  net-tools openssl policykit-1 sed tar traceroute whiptail x11-xserver-utils xz-utils zlib1g zlib1g-dev
95 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/26.8 MB of archives.
After this operation, 3,020 kB disk space will be freed.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  bash dpkg dash diffutils findutils ncurses-bin sed tar bzip2 libbz2-1.0 libtinfo5 libncursesw5 libncurses5
  libreadline6 liblzma5 libaudit1 libpam0g libpam-modules-bin libpam-modules zlib1g-dev zlib1g dmsetup
  libdevmapper1.02.1 libustr-1.0-1 libsemanage1 libnewt0.52 libssl1.0.0 libgpm2 libkeyutils1 libldap-2.4-2
  libcloog-isl4 libcroco3 libffi6 libfontenc1 libgphoto2-port10 libgphoto2-6 libice6 liblcms2-2 mysql-common
  libmysqlclient18 libpciaccess0 libpolkit-gobject-1-0 libpolkit-agent-1-0 libpolkit-backend-1-0 libproxy1
  libwebp5 libsdl-image1.2 libsm6 libxpm4 libxt6 libxaw7 libxdmcp6 libxcb1 libxcb-dri2-0 libxcb-dri3-0
  libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxfixes3
  libxrender1 libxcursor1 libxdamage1 libxi6 libxinerama1 libxrandr2 libxslt1.1 libxtst6 libxv1 libxxf86vm1
  mysql-server mysql-server-5.5 mysql-client-5.5 mysql-server-core-5.5 iptables libxtables10 iputils-ping
  logrotate net-tools traceroute whiptail libxapian22 aptitude xz-utils dpkg-dev libdpkg-perl initramfs-tools
  libglc0 linux-libc-dev openssl policykit-1 x11-xserver-utils
Install these packages without verification? [y/N] y
Reading changelogs... Done
Illegal instruction
Setting up tzdata (2016d-0+deb8u1) ...
dpkg: error processing package tzdata (--configure):
 subprocess installed post-installation script was killed by signal (Illegal instruction)
Errors were encountered while processing:
 tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Do you get this error every time you try to install anything, or is it only when you try to install this particular package? – goobering Jun 2 '16 at 13:06
  • Every time now, even when I try to update the raspi-config tool – BbsMentos Jun 2 '16 at 13:08
2

I suppose there is a possibility you are using a Pi3B and have found a method of using the incompatible architecture in the Debian archives.

However it is more likely you are wrong.

Don't use the Debian archives.

The Raspbian and raspberrypi.org archives are built to support the slightly dated ARM architecture used by the majority of Pi models.

You will need to re-install from scratch.

  • I'm using a Pi B+ and I have this in my sources.list deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi # Uncomment line below then 'apt-get update' to enable 'apt-get source' deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi deb http://ftp.fr.debian.org/debian/ jessie main deb-src http://ftp.fr.debian.org/debian/ jessie main ###### Debian Update Repos deb http://security.debian.org/ jessie/updates main deb http://ftp.fr.debian.org/debian/ jessie-proposed-updates main – BbsMentos Jun 3 '16 at 6:19
  • Expect errors if you use the Debian archives on the Pi. They are compiled for a different architecture. – joan Jun 3 '16 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.