19

I found some related questions about this, yet no answer.

Using a freshly bought "5V/2.1A" rated power supply, I get undervoltage warning icon on both my Raspberry Pi 3s. I measure 4.75V at the USB ports.

I feel like this should not be happening.

  • 7
    What do you want us to say? The power supply isn't delivering 5V which is why you are getting an under voltage warning. – joan Jun 3 '16 at 19:39
  • 2
    Never go by what it says on the label, what matters is what the board sees.. If it is showing the warning you have a problem. This could be caused by what you have connected via the USB ports, or a cheap cable. – Steve Robillard Jun 3 '16 at 19:39
  • I hoped for an explanation why my raspberry shows the warning, even though it is clearly above 4.7V at the Raspberry's USBs. Like I read, the warning should pop up at 4.65V and below. Referencing 5V, these 10~100mV are a huge deal. – LDericher Jun 3 '16 at 20:18
  • Have you calibrated your meter? – joan Jun 3 '16 at 20:52
  • Hey, do you need a digigal multimeter, or is there a vcgencmd command to show how much voltage the board sees? – Tomasz Gandor Sep 7 '17 at 13:19
19

The APX803 chip (which monitors voltage) triggers at 4.63±0.07V.

This is an instantaneous level, whereas your meter will show average. Even assuming your meter is correctly calibrated the trigger may fire if the load varies. The visual trigger has a 3 sec so it will show even if the average is 4.75V (which is already at the lower end of the tolerance range).

The Pi3 actually has a well engineered power circuit, and the SOC will continue to function even if the input voltage is below spec. The same may not be true of the peripherals.

The addition of WiFi and Bluetooth, as well as the faster processor means the Pi3 is more prone to these issues than the Pi2.

Unfortunately the Pi cannot compensate for inadequate power supplies. There are very many of these - I have a few myself, although not as bad as 4.75V.

If you use a cable to connect your PSU to the Pi (if it does not have an integrated lead) you may want to try different leads. Many of the cheaper cables have excessive voltage drop - I actually make my own with decent sized wire.

One of the major causes of problem is high powered peripherals e.g. HDD etc. I suggest you use an external hub if you use these (as do most of us).

It is actually quite simple to design a PSU which would meet the Pi spec, but I couldn't do it for less than $20 which most of the commercial units do. These are really designed to charge smartphones, which they do adequately.

I have tested a number of PSU (with a dummy load) and have yet to find one which actually delivers the rated voltage at the rated current.

  • The only way to deliver the rated voltage is to start with slightly higher voltage to compensate for the inevitable voltage drop. That's why so many adapters are listed at 5.1V or 5.2V. You can minimize the voltage drop by using a lower resistance power cable, as mentioned above. The best cable in this case can be found by searching for "USB charger cable" which typically has heavier gauge wire (18AWG or 20AWG) and is shorter in length. Note that these charge-only cables do not contain data wires, as they're not needed, so you can't use them for a general purpose USB data connection. – PhilM Jun 4 '16 at 4:39
  • @PhilM This is the brute force approach. An engineering approach is to have the feedback connections to the regulator attached at the output, which is how I would design a PSU. – Milliways Jun 4 '16 at 4:57
  • 1
    I agree with your comment. It's a cost tradeoff between the simple (brute force) solution to increase the output voltage and use a lower resistance cable, versus a constant voltage regulator in the PSU. – PhilM Jun 4 '16 at 17:19
  • Is there a way to monitor the APX803 measurements from within the filesystem? Something like: vcgencmd measure_volts or cat /sys/.../volt? (I made that up.) – not2qubit Jan 3 '18 at 21:29
  • 1
7

I would suggest that your power supply is the problem. I had exactly the same issue on my Pi 3 with a power supply I sourced on Ebay rated at 2.1A/5V, I tried an official 2.5A/5.1V supply and all my problems went away: Official RPi power supply

This article claims the minimum voltage requirement to be 4.8V: RPi Minimum Voltage

  • I did some measurements with um25c and it appears that my raspberry displays lightning bolt even when voltage drops to ~4v9. If the voltage drops to ~4v8 the boards reboots. Not sure, if it could be caused by the bad quality of my board though. – Grief Nov 13 '18 at 19:57
6

In such cases, please have a look at the USB cable, they have often a high internal resistance which causes the voltage drop. For USB data it's not a problem, but for USB Power (if the connected device checks the voltage).

  • Thanks, this was my issue. Using a different cable from the power supply negated the warning. – lux Jun 28 '18 at 19:46
2

I assume you're referencing this question from the official Raspberry Pi Foundation's forum. If you look at the post again, you'll notice that the post was written in 2014. Your question states that you're using a Raspberry Pi 3 which was released in 2016.

I haven't been able to find a more recent posting from the foundation, but one could simply assume that the warning is displayed at a different threshold for the RPi 3. Since the RPi 3 requires significantly more power, it makes sense that it would have a tighter tolerance.

  • 1
    Actually the circuitry of the B+ and Pi3 (which are the only published circuits) are very similar. The voltage sensing is the same, although the connection to the SOC differs. The Pi3 has improvements to cater for higher currents. – Milliways Jun 4 '16 at 1:00
  • 1
    Carefull. The increased power-need of the RPi3 is amperage, not voltage. – tlhIngan Jun 4 '16 at 5:33
2

Try to use another cable in order to connect your power supply to your Raspberry Pi. Thin and long cables result in high voltage drops over the cable because of the high current. In my case, this caused the undervoltage warning. I ended up cutting a thick USB extension cable shortly after the USB plug and connecting it directly to the Pi's GPIOs. Now, everything works fine.

1

Indeed, this problem is, 9 times out of 10, the cable. Even when you may think it can't be.

I recently tacked this issue with a very good power supply (12V, 2A) through a 3A 5V switching regulator, which was fed into the Pi using 8 inches of somewhat inferior USB cable. Constantly giving under-voltage warnings.

However, trim those 8 inches down to just 2 inches of inferior cable (all I wanted it for was the plug) and magically the warnings vanished. Gone. Nada.

You wouldn't think that just 6 inches would make any difference... but the Pi3B+ is just so sensitive (overly sensitive if you ask me... I *don't * need to know if the supply has dropped out for 23 picoseconds) it borders on paranoia.

0

My Pi 3b runs off a 7.2Volt 3600mA NiMh Rc-car powerpack. With a MB102 breadboard power supply module that can take from 6.5 to 12Volt input and outpits 5 and 3.5volts...

Thisone to be exact: http://www.petervis.com/Raspberry_PI/Breadboard_Power_Supply/YwRobot_Breadboard_Power_Supply.html

And I never get undervoltage warnings.

PL.

protected by Community Jul 18 '18 at 11:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.