2

I have Debian Jessie 8.4 running on my Raspberry Pi 3 (download the latest Raspbian image, flash that onto an SD, boot the Pi off it, resize the filesystem with raspi-config, put the SD back in my computer, mount the ext partition and delete every file on it but keep the partition table and the boot partition, debootstrap --arch=armhf jessie, and make a FSTAB). But I can't get the WiFi to work (the RPi 3-specific on-board WiFi adapter). It doesn't show-up when I run ifconfig -a, but I know it's not a non-RPi-specific-distribution-issue because it doesn't show-up when I run ifconfig -a on Raspbian and it doesn't appear on the list of adapters in WPA_gui (also on Raspbian). I also do not think it is a hardware issue because I have tried those steps on two different Raspberry Pi 3s purchased months apart, one when the Raspberry Pi 3 came out and one recently. What do I have to do to get the on-board WiFi antenna working as an interface?

1

Look at this closely-related question. Same issue as you, but with ArchLinux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.