I try to configure my new Raspberry Pi to play flash (AVM2) (with deezer.com for example). I'm really new on *NIX systems so I tried several things:

First I installed gnash. Then I tried to install lightspark (for AVM2). However, it failed with an error and the flash didn't work.

This document seemed to help but when I run cmake it emits several errors:


-- Found gnash path: /usr/bin/gnash
-- The ASM-NASM compiler identification is unknown

-- Found assembler: /usr/bin/nasm

-- LLVM llvm-config found at: /usr/bin/llvm-config

-- LLVM version: 3.0




-- LLVM CXX flags: -I/usr/lib/llvm-3.0/include -DNDEBUG -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -g -O2 -fomit-frame-pointer -fno-exceptions -fPIC -Woverloaded-virtual -Wcast-qual

-- LLVM LD flags: -L/usr/lib/llvm-3.0/lib -lpthread -lffi -ldl -lm

-- LLVM core libs: -lLLVMLinker-lLLVMArchive-lLLVMBitWriter-lLLVMBitReader- lLLVMInstrumentation-lLLVMipo-lLLVMScalarOpts-lLLVMInstCombine-lLLVMTransformUtils-lLLVMipa-lLLVMAnalysis-lLLVMTarget-lLLVMMC-lLLVMCore-lLLVMSupport-L/usr/lib/llvm-3.0/lib

-- LLVM JIT libs: -lLLVMARMDisassembler-lLLVMARMAsmParser-lLLVMARMCodeGen-lLLVMSelectionDAG-lLLVMAsmPrinter-lLLVMMCParser-lLLVMARMDesc-lLLVMARMAsmPrinter-lLLVMARMInfo-lLLVMJIT-lLLVMExecutionEngine-lLLVMCodeGen-lLLVMScalarOpts-lLLVMInstCombine-lLLVMTransformUtils-lLLVMipa-lLLVMAnalysis-lLLVMTarget-lLLVMMC-lLLVMCore-lLLVMSupport-L/usr/lib/llvm-3.0/lib

-- LLVM JIT objs:

-- Found LLVM: /usr/lib/llvm-3.0/include

-- checking for module 'liblzma'

--package 'liblzma' not found CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message): A
required package was not found Call Stack (most recent call first):


(_pkg_check_modules_internal) CMakeLists.txt:249 (pkg_check_modules)

CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:395
(MESSAGE): Please install the Boost libraries AND development

packages Call Stack (most recent call first): CMakeLists.txt:257


-- Configuring incomplete, errors occurred!

Liblzma is comes with XZ Utils which is installed. Boost is also installed.

So I don't understand why lightspark can't be installed.

Could someone help me? :)


I left my other answer here for the information; it is actually the direct answer, BUT it seems to me you do not have to build lightspark at all. It is already available precompiled for raspbian (to understand what that means, read my other answer):

> apt-cache search lightspark

browser-plugin-lightspark - High-performance SWF player - Mozilla Plugin (experimental)
lightspark - High-performance SWF player (experimental)
lightspark-common - High-performance SWF player - common data
lightspark-dbg - High-performance SWF player (experimental) - Debug symbols

Probably a simple apt-get install browser-plugin-lightspark will get you what you want.

  • I've installed the browser-plugin-lightspark and lightspark. Unfortunately it crashed on deezer.com but this is a other problem. Thanks for your help ! – Guillaume Wuip Feb 10 '13 at 19:13
  • BTW if you just want a working flash for mozilla, installing the adobe one from their site into firefox is very easy. I have not tried it on minora or the pi, but if you leave another note here I will, and explain that how to do that. – goldilocks Feb 11 '13 at 9:31
  • 1
    Adobe published a ARM version of flash ? – Guillaume Wuip Feb 12 '13 at 11:17
  • @Wuip : oh heck I guess not...well never mind that then. Closed source sucks! – goldilocks Feb 12 '13 at 12:42

Library packages on linux are pre-built binaries for use by other pre-built packages. "Build/building/built" and "compile/compiling/compiled" are synonymous in this context. A binary (synonym: executable, or "binary executable") is compiled from source code but it is not the same thing as the source code and the source code is not included in the binary.

This is also how other popular desktop OS's (windows, mac) work. The software is compiled from source code by somebody somewhere and they package it, then you install the binary executable package.

Sometimes, however, a piece of software has not been pre-built for use on a particular system (eg, raspbian). In this case you must build the software from the source code, which is what you are trying to do with lightspark. In order to do this, you need some source code "glue" for any libraries that this software makes use of (FYI: not all the source code, just a few small bits, called the header files or "includes" used as a plural noun, meaning, "things you include"). That glue is not included in the basic library package, because it is not normally needed. It is only needed for compiling code.

So, even though you may have the lzma library installed, you may not have the glue code required to build things with it. Most likely, that is what the makefile is looking for. For raspbian, that glue will be in a -dev package. The dev package does not replace the library. It just installs a few extra bits that, again, are not normally needed.


> apt-cache search lzma | grep dev

The apt-cache search command searches for software available in the raspbian repository; the results are then filtered through the grep dev command to weed out hits that do not contain the word 'dev'.

libarchive-dev - Multi-format archive and compression library (development files)
liblz-dev - data compressor based on the LZMA algorithm (development)
liblzma-dev - XZ-format compression library - development files
lzma-dev - Compression and decompression in the LZMA format - development files

So, you could try installing the liblzma-dev and lzma-dev packages.

  • Thanks for you help. If I understand the good way, cmake does not find liblzma beacause their is no liblzma but liblzma-dev ? How could I tell cmake to take liblzma-dev instead ? – Guillaume Wuip Feb 10 '13 at 17:12
  • @GuillaumeWuip It's not "instead"; they are two parts of the same thing. Usually you don't need the dev part. I've re-written to explain that more clearly. – goldilocks Feb 10 '13 at 18:21
  • Ok, I've understand the system. Your explanation is very useful.Thank you very much ! – Guillaume Wuip Feb 10 '13 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.