Wits end is coming.

I've installed Kodi on my Raspberry Pi 3 running Raspbian hooked up to a Samsung UE46EH5000 (non-smart, non-cec) TV running at 1920x1080 resolution. When playing a video of any type, I get black screen (menu overlays are all there, just no content), sometimes audio, sometimes a freeze at 0:0:0. And sometimes a spinning ranbow grid centre screen (not the PI low power rainbow grid upper right: I had that for a while but I upgraded power supply).

So far I've tried: --Turning off all Hardware Acceleration

--Switching from MMAL player to OMXPLayer

--Switched HDMI Cable

--Removing all add-ons I've added

--Clean install (including killing the .kodi/userdata directory) no additional addons

--Upgraded power supply to 2.4 amps

--Turning on Adjust display refresh rate

--Turning on Sync playback to display

I put the log file in its entirety here.

The suspect bits I see are:

ERROR: CMMALRenderer::init_vout Failed to vout enable input port (status=1 ENOMEM) 08:02:26 T:1611121584 ERROR: OutputPicture - failed to configure renderer

NOTICE: fps: 23.976024, pwidth: 624, pheight: 352, dwidth: 624, dheight: 352 08:04:44 T:1038087088 NOTICE: Display resolution DESKTOP : 1920x1080 (1280x720) @ 60.00 - Full Screen (16)

08:04:47 T:1936716720 ERROR: COMXCoreComponent::EmptyThisBuffer component(OMX.broadcom.audio_mixer) - failed with result(0x80001018) 08:04:47 T:1936716720 ERROR: CActiveAEResamplePi::Resample OMX_EmptyThisBuffer() failed with result(0x80001018)

On startup, Kodi iniitalizes the Pulse 8 add on for CEC support -- as I don't have CEC, I thought about disabling this, but haven't found a way to do that. Guidance on that or any other theories about why Kodi isn't working would be welcome.

  • What type of video file are you trying to play? Have you checked the files play correctly on your computer? What about a fresh install of Kodi? It could be some important files got corrupted at some point.
    – Darth Vader
    Jun 5, 2016 at 11:24
  • Tried .mkv, .avi -- known good files from a usb drive I regularly plug straight into the TV. And I've now done two fresh installs, one of Kodi and another of the entire raspbian OS.
    – brianfit
    Jun 5, 2016 at 12:29
  • Maybe the problem is in the USB drive? What sort of drive is it? Have you tried playing files off the SD card, or using a program like YouTube?
    – Darth Vader
    Jun 5, 2016 at 17:26
  • Ah, good thought -- it's an old Seagate external drive with its own power source. But just tried playing from a USB stick and the SD card, no change.
    – brianfit
    Jun 5, 2016 at 18:14
  • I had something similar; the reason seems to have been a broken kodi package. Re-running aptitude safe-upgrade resp. dpkg-reconfigure kodi solved the issue.
    – Raphael
    Mar 4, 2019 at 6:40

2 Answers 2


ERROR: CMMALRenderer::init_vout Failed to vout enable input port (status=1 ENOMEM)

Try editing into your /boot/config.txt:

gpu_mem_1024 = 128

If that does not work, increase the number to 256; the default is 64 and the units are MB of RAM dedicated for use by the GPU (so you probably want to do this in conjunction with a "hardware acceleration enabled" setup).

If 256 does not solve the problem, then this is not the issue.

  • Thanks. Tried each setting, rebooted, and toggling hardware acceleration between default settings and none, no change.
    – brianfit
    Jun 5, 2016 at 13:42

After several days of fiddling, I took the nuclear option and installed OpenElec instead of Raspbian. Night and Day. Up and running flawlessly in 5 minutes.

  • This is route I took as well. Wish there was a better answer, since I need to be able to use a web browser, which IIRC is not supported in OpenElec. I'm dual booting with Raspbian to run the browser, but it isn't ideal.
    – chue x
    Jun 22, 2016 at 17:37
  • brianfit +1 I had the same problem with Raspbian+Kodi. Changed to LibreELEC and all worked fine. LibreElec is an OpenElec fork so it should work too. I liked idea of having a flexible linux but my main use is video so... raspbian't. Aug 28, 2018 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.