2

I want to grab video using easy cap on my raspberry pi 3. I followed the link http://raspberry-at-home.com/video-grabber-for-raspberry-pi/, but I am getting only green screen.

root@raspberrypi:~ $ uname -a
Linux raspberrypi 4.4.11-v7+ #888 SMP Mon May 23 20:10:33 BST 2016 armv7l GNU/Linux

root@raspberrypi:~# lsusb
Bus 001 Device 004: ID 04ca:0061 Lite-On Technology Corp. 
Bus 001 Device 005: ID 1a2c:0023 China Resource Semico Co., Ltd 
Bus 001 Device 012: ID 1b71:3002  
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

root@raspberrypi:~# arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: usbtv [usbtv], device 0: USBTV Audio [USBTV Audio Input]
Subdevices: 1/1
Subdevice #0: subdevice #0

root@raspberrypi:~# cat /proc/asound/cards
0 [ALSA           ]: bcm2835 - bcm2835 ALSA
                  bcm2835 ALSA
1 [usbtv          ]: usbtv - usbtv
                  USBTV Audio at bus 1 device 12

How to resolve this issue?? any suggestion will be appreciated.

2

Have a look at: http://easycap.blogspot.de/2013/03/raspberry-pi-and-easycap-devices.html

The video is green if there is no signal connected to the easycap. You may check the connection of the video input.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.