2

I am currently trying to connect to my Raspberry Pi B+ from my Macbook Pro (El Capitan) using the following TTL USB cable: https://www.pi-supply.com/product/usb-ttl-serial-cable-debug-console-cable-raspberry-pi/?aelia_cs_currency=GBP&feed_country=GB&gclid=CP-p6tLqlc0CFbcW0wodzGoIqA

After completing the 0xc0de's tutorial (http://www.0xc0de.net/2015/09/getting-adafruit-serial-cable-to-work.html), my computer could recognise the new hardware under "cu.usbserial".

However, when I try to connect using the computer's terminal (typing: screen /dev/cu.usbserial 115200), I get the following errors instead of the expected login prompt:

    [ 6297.097173] systemd[1]: Unit systemd-journald.service entered failed state.
    [ 6287.029730] systemd[1]: systemd-journald.service has no holdoff time, scheduling restart.
    [ 6287.044138] systemd[1]: Stopping Journal Service…
    [ 6287.056453] systemd[1]: Starting Journal Service…
    [ 6287.082128] systemd[1]: Started Journal Service.

The above messages are repeating continuously.

The rasperrby Pi is running a fresh version of Raspbian (Jessie), which is perfectly working when connecting through SSH.

Does anyone have any idea/advices about how to solve this problem ? Please don't hesitate to ask any additional information.

Best regards

EDIT: I get the exact same error when connecting using the application called "SerialTools" (freely available the AppStore) instead of the computer's terminal

0

If it can help anybody, I finally solved my problem by powering the raspberry pi with an external power source while leaving disconnected the VCC pin of the TTL cable (red jumper).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.