6

Which is the recommended toolchain to cross-compile Qt5.6 for Raspberry Pi 3? I tried official tools:

https://github.com/raspberrypi/tools

but it seems they don't support the architecture and flag required for RPi3:

QMAKE_CFLAGS            = -march=armv8-a+crc -mtune=cortex-a53 -mfpu=crypto-neon-fp-armv8 -pipe -Os -mthumb
QMAKE_CXXFLAGS          = $$QMAKE_CFLAGS -std=c++1z
  • The foundation seems to go forward with ARMv7 compatibility mode on the Pi3. Note that the Pi3 AArch64 kernel is still considered experimental. – flakeshake Jun 20 '16 at 9:08
2

I'm going through the same thing. You need to use the 4.9.2 compiler:

Look under arm-bcm2708 for the arm-rpi-4.9.3-linux-gnueabihf folder.

I still haven't been able to cross-compile QT for Pi3, but I'm working on it.

My adventure can be found here: http://forum.qt.io/topic/67942/failed-cross-compile-bad-architecture

  • I don't know what are the differences, but I was able to compile Qt5.6 for RPi3 using the gcc-linaro-arm-linux-gnueabihf-raspbian cross-compiler and the mkspec for RPi2 (without ICU). Perhaps it would work also with the arm-rpi-4.9.3-linux-gnueabihf. I will try whenever I have some spare-time. – Mark Jun 12 '16 at 9:29
0

On Windows, I've used arm-linux-gnueabihf (see http://visualgdb.com/tutorials/raspberry/qt/embedded/), and MinGW64. It worked well. Don't hesitate if you want more details

0

Just change -std=c++1z to -std=c++11, and it will be recognized. Indeed version 4.9.3 is C++11 compliant.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.