1

I have run into something seriously weird. It used to work and then from one day to the next it has stopped working.

My Setup: - Stream 7 Tablet with Win10 - Raspberry Pi Model 2B with Vilros plug and play Wlan dongle

What I did in the past:

  1. On Win10 tablet:

    a. netsh wlan set hostednetwork mode=allow ssid=adhocname key=password

    b. netsh wlan start hostednetwork

    c. Then I simply waited until the RPi automatically connected

    d. ping the RPi: ping raspberrypi.mshome.net

    e. ....ssh into the pi

but now for some reason when I try ping the pi it returns either;

  • request timed out OR
  • Reply from 169.254.155.200: Destination net unreachable

anyone got any ideas please? NOTE Windows firewall is turned off completely. Not sure, but that didnt make a difference in the past.

Why would it work perfectly fine the one day yet the next not.

Any help would be greatly appreciated

  • Have you tried shutting everything down including the router. Then bring them up one at a time with router being first then the devices? Could be a lease issue maybe? – Dan V Jun 8 '16 at 21:41
  • I am not using a router. I am connecting the pi directly to the tablet. And yep, Ive shut down everything too. Thanks – Misha Jun 8 '16 at 21:51
  • Ah ok, didn't see a mention that it was direct device to device. – Dan V Jun 8 '16 at 21:53
1

Right so one solution I have found is to rollback or format the tablet completely. (keep your files though)

There were one or two internet security packages I installed and then subsequently uninstalled. I think they are what caused the change somewhere somehow.

So if you do run into the same issue, yay for you, just format, it will save you a lot of time.

0

This might be too simple an answer, but have you checked that it's still on the same ip?

  • how do you mean? the IP on the tablet is left floating. I have tried changing it to that of the pi's (excl last digit ofc), once connected, but no luck. I havent changed any ip settings on the pi itself. But pinging "raspberrypi.mshome.net" should take care of assigned ip's on the pi, should it not? – Misha Jun 8 '16 at 21:21
  • Do a network discovery to find the actual IP of the Pi, as it is expected to change every time it connects to the wifi. – tlhIngan Jun 8 '16 at 23:00
  • The ip of the pi was not the issue. I tried using the actual ip too, but as said, if the actual ip does not work then "ping raspberrypi.mshome.net" will not work either and visa versa. Check my above solution – Misha Jun 10 '16 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.