1

I recently bought the Powerline, so like this I can transfer Internet via the electric cable line from the wireless LAN router to another place where the wifi is not covered. In this last I connected my raspberry pi 3 via wifi to the network created by the powerline. The problem now is that when do ping or SSH from the network created by the Powerline everything work ok, but when I want to access trought the wifi from raspberry created by the router I can not. By arp -a can see the the raspberry ip address of the second network but can not access. Does anyone have the same problem?

  • Which OS are you using to access Pi ? Is it windows 7 ? – Nik Jun 9 '16 at 15:29
0

From your post, I'm understanding that was the whole reason you are using a Powerline Ethernet Adapter. The wifi on your Raspberry Pi 3 is not able to connect to your wireless router, due to it's location. If that be the case, then the raspberry pi 3 cannot establish the wireless connection or it's too intermittent and does get an ip address enough for some time, but looses it's connection, thus no Ping or heavy packet drops.

I would suggest disabling the wireless all together via your desktop, assuming your running something like Raspbian (Jessie), or through the command line.

Edit your "interfaces" file to exclude wifi connection, simply run:

sudo nano /etc/network/interfaces

comment out (by placing a # (pound sign)) in front of all the lines releated to the wlan0 interface. Assuming that's your interface:

#allow-hotplug wlan0
#iface wlan0 inet dhcp
#wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Press "ctrl" and "O" to save file, the "ctrl and "x" to close nano. Finally, run:

sudo reboot

For settings to take effect.

Maybe this will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.