Yesterday I've received my Raspberry Pi, and there are some issues I can't get rid of...

After a few minutes (3-4 minutes to be exact) of seemingly error free work session through SSH, the network status LEDs turn off, the Pi freezes. It doesn't respond to any to any requests through the network, can't be pinged, also the same thing happens when I attach a keyboard/Mouse/Monitor and use these to access the pi.

I'm running the latest wheezy from an 8 GB Kingston SD Card, and tried 2 power supplies each capable of outputting more than 500 mA (700 mA & 1 A) and no overclocking.

  • It does sound like a power issue. What else do you have plugged in?
    – Jivings
    Feb 13, 2013 at 9:05
  • I've done the multimeter voltage test on my pi using a 5v==2A and 5V==1.2A supply; with nothing attached to the USB ports, neither of them gets it over 5V, and it's 0.1 V less with the 1.2A, putting it near the bottom of the acceptable range: elinux.org/Rpi_Hardware#Power It goes down more when something is attached. If yours is like mine, you need a 2A supply minimum.
    – goldilocks
    Feb 13, 2013 at 10:12
  • @goldilocks: good to know... I've bought a "stock" PS that optinally comes with the PI from , and it's 5V==0.7A according to the label on the PS... I'll get a 5V==3A PS to be sure...
    – Meki
    Feb 13, 2013 at 14:41
  • @Aznim: Beware I'm no electronics guru...that Hardware#Power link also mentions resistance in the microUSB cable, of which I only have one. You definitely want to do the multimeter test before jumping to conclusions (a cheap multimeter is about $10-15 at a hardware store).
    – goldilocks
    Feb 13, 2013 at 14:52

2 Answers 2


Had the same issue too. This causes a "bug" which freezes the SoC Controller.

I've succesfully fixed this with the following options:

Add the following to /boot/cmdline.txt (which must remain as one line):

smsc95xx.turbo_mode=N dwc_otg.dma_enable=1 dwc_otg.dma_burst_size=256 elevator=deadline
  • view dwc_otg parameters and their description here

  • smsc95xx.turbo_mode=N - sets the Network device not in turbo mode. Usually you don't see a difference on network traffic

  • elevator=deadline - sets the scheduler to deadline Sched (more information here)

  • I have the same problem (it's not font for sure) and those commands, unfortunately, had no effect. More sugestions?
    – blagus
    May 22, 2015 at 23:25

I've tried the power supply solution, not that I thought that could be the problem. I then tried the /boot/cmdline.txt change and that didn't work either. I'm running my RasPi with only a network connection, nothing else, access is via ssh and vnc, so when the network goes down.... I did notice earlier that when I plugged in a keyboard and/or a mouse or a Wi-Pi (wifi usb device) the RasPi rebooted itself! This is my second Pi, the first one had none of these problems and has run without problems for ~1 yr. The first one was an early 512 model, this one is later. My quess is that the later one has a serious h/w fault. Looks like the solution is the bin! As a teaching aid the Pi is excellent, good way to spend a day to discover the hard way the economics of hi tech manufacturing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.