1

Has anybody successfully installed Julius on a RPi3? I am trying to configure this on a Raspberry Pi 3 B running Raspian (Non-noobs install). I am trying to use a Logitech C270 webcam as my audio input device.

I have almost accomplished this using the following steps:

1.) sudo apt-get install alsa-tools alsa-oss flex zlib1g-dev libc-bin libc-dev-bin python-pexpect libasound2 libasound2-dev cvs

2.) After downloading and installing the above packages I can record and play back audio with the following commands:

arecord -d 10 -D plughw:1,0 test.wav

aplay test.wav

3.) Download Julius form CSV with the following command:

cvs -z3 -d:pserver:anonymous@cvs.sourceforge.jp:/cvsroot/julius co julius4

4.) Export variable environment with:

export CFLAGS="-O2 -mcpu=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard -pipe -fomit-frame-pointer"

5.) Compile Julius on Raspberry Pi using the following commands

cd julius4 ./configure –with-mictype=alsa make sudo make install

Unfortunately this is where I get stuck. I get an error on ./configure –with-mictype=alsa

The configuration process reports: (only showing the last two lines)

configure: error: mictype not supported, or specified type not exist

configure: error: ./configure failed for libsent

After reading through the configuration manual for Julius I thought that perhaps setting the config to auto would work. This is done using the following command: ./configure –with-mictype=auto

STILL same error. I am starting to think that there is an issue with the index of my sound capture device.

If I type in cat /proc/asound/cards it returns

0 [ALSA ]: bcm2835 - bcm2835 ALSA

                 bcm2835 ALSA

1 [U0x46d0x825 ]: USB-Audio - USB Device 0x46d:0x825

                 USB Device 0x46d:0x825 at usb-3f980000.usb-1.3, high >speed
-2

did you try sudo ./configure...

you can look this too

https://github.com/julius-speech/julius/issues/40

  • 2
    Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Ghanima Sep 5 '16 at 19:54
0

I know it's very late (2019) but using --with... instead of -with... made a big difference. easy to miss

  • 1
    Yes, you are right, but the question has already an accepted answer. So it seems the questioner doesn't have a problem with that option. – Ingo Apr 9 '19 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.