0

I'm trying to set up GitLab on Raspberry Pi 2. I have connected external HDD to the Raspberry to store the repositories.

I have mounted the external HDD to /mnt as a fuseblk file system. This can be seen in the following print given by command df -T:

    Filesystem     Type     1K-blocks    Used Available Use% Mounted on
    rootfs         rootfs     6520152 3802404   2363496  62% /
    /dev/root      ext4       6520152 3802404   2363496  62% /
    devtmpfs       devtmpfs    470368       0    470368   0% /dev
    tmpfs          tmpfs        94936     232     94704   1% /run
    tmpfs          tmpfs         5120       0      5120   0% /run/lock
    tmpfs          tmpfs       189860       0    189860   0% /run/shm
    /dev/mmcblk0p5 vfat         61302   14566     46736  24% /boot
    /dev/sda1      fuseblk  125034752   30336 125004416   1% /mnt

I configured the GitLab to store the repositories there by modifying the /etc/gitlab/gitlab.rb file and in that file changing the line with git_data_dir to git_data_dir "/mnt/gitlab/git-data".

When I run command sudo gitlab-ctl reconfigure I get the following error message:

Error executing action `create` on resource 'directory[/mnt/gitlab/git-data/repositories]'

Errno::ENOSYS
-------------
Function not implemented @ chown_internal - /mnt/gitlab/git-        data/repositories

Resource Declaration:
---------------------
# In /opt/gitlab/embedded/cookbooks/cache/cookbooks/gitlab/recipes/gitlab-shell.rb

         33:   directory repositories_path do
         34:     owner git_user
         35:     group git_group
         36:     mode "2770"
         37:     recursive true
         38:   end
         39:

I have tried searching the answer to this problem and what I found out is that this error is due to the fact that chmod doesn't work on files on the external HDD in fuseblk format. When I try chmod on any file in external HDD I get the following message:

chmod: changing permissions of `test': Function not implemented

I would like to know if there is a way to get around this or if there is some file system which I could use instead of fuseblk which would implement chmod?

closed as off-topic by Milliways, Jacobm001, Patrick Cook, joan, goldilocks Jun 28 '16 at 11:17

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be specific to the Raspberry Pi within the scope defined in the help center." – Milliways, Jacobm001, Patrick Cook, joan, goldilocks
If this question can be reworded to fit the rules in the help center, please edit the question.

1

After more investigation I was able to solve the problem by emptying the hdd and formating it to ext4 format which supports the chmod command. After this the gitlab reconfigure command run without errors.

I followed a tutorial which can be found here: http://www.makeuseof.com/tag/how-to-add-usb-storage-to-the-raspberry-pi/

Not the answer you're looking for? Browse other questions tagged or ask your own question.