1

I've been trying to setup my HL-L2300D printer. I downloaded the driver from Brother, hooked up the printer via USB, and everything looks like it should work. However, it doesn't print.

Here is the system details

  • Raspberry Pi 3 Model B
  • Raspbian GNU/Linux 8 (jessie)
  • CUPS 1.7.5
  • Brother HL-L2300D
  • Brother Linux driver

Everything looks like it should work. The HL-L2300D shows up on the USB port and CUPS website shows everything is good (even PDF printing with CUPS works). I would appreciate any help.

1
  • 1
    I suspect the problem is that the driver is built for x86 and AMD64, not ARM. There's a thread at raspberrypi.org/forums/viewtopic.php?f=28&t=15526 where they talk about this issue with a similar printer. Long-ish thread, but perhaps worth a read. People reported success just a few months ago.
    – Mark Smith
    Jun 13, 2016 at 10:49

3 Answers 3

0

I did not look at the driver, but since there is no indication to the contrary on the download page, I would assume what Mark Smith points out: It will not be in the proper binary format for the Raspberry Pi.

A primary characteristic used to classify processors is their architecture. By far the most widespread architecture used in desktop and laptop computers today is the performance oriented x86(-64) ISA, used and developed by Intel and AMD. For mobile and embedded devices, it is the more energy and cost efficient oriented ARM ISA, of which there are various subcategories with varying degrees of compatibility. The Pi is ARM based (the 3 is ARMv8, the 2 ARMv7, all the others are ARMv6).

For whatever reason, printer manufacturers are particularly virulent about considering their drivers intellectual property. They do not distribute source code or publisize the communication protocols used, and although the latter can be reverse engineered, the constant evolution and myriad array of printer models makes it very difficult for anyone doing this to keep up, particularly since they are not likely to be compensated for their efforts.

Anyone who has tried to get a printer to work from a smartphone has likely run into this problem and some major manufacturers (at least up until fairly recently) charged large licensing fees to anyone making apps that served this purpose, so despite having spent a few hundred bucks on their printer, you still may have to pay them (directly or indirectly) another $20 just to use it with your phone. :/

Since Android is linux kernel based and many smartphones share the same architecture as the Pi 2 and 3 (less likely with A/B/+/0 models), it might not be impossible to adapt those for use on the Pi, although I do not know how truly feasible, difficult, or legal this would be.

To summarize: You are out of luck with this.

0

I was able to make exactly this printer work on my Raspi using this howto: https://www.lhinderberger.de/pi/2016/01/27/raspberry-pi-binary-x86-drivers.html

5
  • 1
    Thanks, that worked. I had to reinstall rasbian and start from stratch, but it worked in the end. Sep 16, 2016 at 7:30
  • Alas! The link is dead! Can you please summarize the HOWTO here?
    – einpoklum
    Jul 27, 2018 at 20:08
  • To be honest, I can't but the howto emerged in this thread: raspberrypi.org/forums/viewtopic.php?t=127401#p889314 Maybe you can reconstruct it from there?
    – Photon
    Jul 28, 2018 at 18:37
  • 2
    Not yet allowed to comment in this community, so in response to @photon's link to forum.manjaro.org, the link is dead, so here's an archive.org link that seems to have a backup of the page: web.archive.org/web/20200725181408/https://forum.manjaro.org/t/… Sep 5, 2020 at 23:59
  • @chunk_split Fixed the link in my answer, thanks for pointing out that it is broken!
    – Photon
    Sep 6, 2020 at 11:49
0

I have now managed to make the printer work and wrote up the steps in a little tutorial: https://archived.forum.manjaro.org/t/how-to-set-up-a-remote-printer-which-is-attached-to-a-raspberry-pi-or-any-other-arm-computer/57056

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.