5

I have a Raspberry Pi 2 Model B, running Raspbian Jessie. I'm trying to set up http://raspberrypints.com for my home brewery. I have it running on the default web browser, however I can't get Chromium to work so it will auto start into kiosk and be full screen.

I ran sudo apt-get install chromium-browser and it installed the newest version 50. I go to launch Chromium, I can see the CPU ramp up to 100% and the mouse gets a timer icon, but then nothing. Chromium never launches. If I try to run chromium-browser from the Terminal I get an "illegal instruction" error.

Added @chromium –kiosk localhost to /etc/xdg/lxsession/LXDE-pi/autostart and it won't start on reboot either.

I've uninstalled and reinstalled Chromium multiple times to no avail. Is v.50 not compatible with Jessie?

Or is there a way to get it to boot into the default browser in full screen mode? I don't mind having to use the default web browser, just want it to boot full screen so there is no menu bar. And would at least like to get Chromium to run since it's driving me crazy not being able to get it to work.

  • 1
    I don't think Chromium available through apt-get method. The last time I installed them through dpkg. This link might help goo.gl/iLfgo8 – xdhe Jun 14 '16 at 9:15
  • 1
    Forgot to mention, the sudo apt-get didn't work at first. I then tried the method mentioned here to install it: raspberrypi.org/forums/viewtopic.php?t=121195 It appeared to install and tries to launch, cpu at 100%, mouse spinning icon and then nothing. I uninstalled it and then ran the sudo apt-get install chromium browser command which then appeared to work. It says it installs, icon in Internet menu but won't launch and illegal instruction error when trying to open from command line. – HopHead73 Jun 14 '16 at 10:10
  • weird, i can execute chromium-browser through terminal with display on, not through ssh. Btw, i'm using Chromium v45, installed through dpkg. – xdhe Jun 14 '16 at 10:41
  • It's very weird. I'll try uninstalling and installing v45 with the method you mentioned tonight. – HopHead73 Jun 14 '16 at 10:59
1

May have found the answer to all my problems: http://www.raspberry-projects.com/pi/pi-operating-systems/raspbian/gui/auto-run-browser-on-startup

I just need any web browser to boot in full screen mode for this tap list to work and look good and since Chromium refuses to work, but the tap list works fine on Midori this should solve all my problems.

  • To anyone trying to do this on Jessie, you have to add the web browser autostart command to: ~/.config/lxsession/LXDE-pi/autostart NOT the autostart file in /etc/xdg/lxession/LXDE-pi/autostart like it use to be! – HopHead73 Jun 15 '16 at 1:42
0

As far as I know the chromium is not available for Jessie version of Debian... But it's still available for its previous version wheezy .

0

It isn't available in Jessie, but is included with the new Raspbian + PIXEL update. (Epiphany, NetSurf, and Dillo are still included)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.