3

I have a Tp Link TL-WN823N version 2 wifi dongle and raspberry pi (B+) doesn't seem to recognize it

not sure if that "v2" makes a difference or not

The OS is raspbian jessie

The kernel version is 4.4.13+ #894 Mon Jun 13 12:43:26 BST 2016 armv6l GNU/Linux

lsusb lists it as Bus 001 Device 004: ID 2357:0109

and dmesg | grep usb lists shows this for the device

[    3.904323] usb 1-1.5: new high-speed USB device number 4 using dwc_otg           
[    4.015470] usb 1-1.5: New USB device found, idVendor=2357, idProduct=0109        
[    4.024625] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3   
[    4.033813] usb 1-1.5: Product: 802.11n NIC                                       
[    4.039971] usb 1-1.5: Manufacturer: Realtek                                      
[    4.046137] usb 1-1.5: SerialNumber: 00e04c000001        

I am not sure if it is a driver problem or is my device faulty. or something else

I also tried it on pi2 with kernel version 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux with similar result

Edit:

The solution was to return the device as it did not work ;)

0

2 Answers 2

0

TL-WN823N version 2 wifi dongle

I think you are out of luck with that one.

dmesg | grep usb lists shoes this for the device

Well, not really. That is just information provided via standard USB protocol by the device in order to identify itself. Such information is then used by the kernel to check and see if any "shoes" are available. There's nothing there to indicate any were found.

Looking here, another version of that device (the first one, I guess) used the Realtek RTL8192CU chipset, for which there is a potential driver. But that identifies itself with a different ID (0bda:8178 vs. 2357:0109).

Grepping through the kernel 4.5 source drivers/net/wireless/realtek for 2357 shows a couple of things for a chipset that would be identified as 2357:0100:

./rtlwifi/rtl8192cu/sw.c:       {RTL_USB_DEVICE(0x2357, 0x0100, rtl92cu_hal_cfg)}, /*TP-Link WN8200ND*/
./rtl8xxxu/rtl8xxxu.c:{USB_DEVICE_AND_INTERFACE_INFO(0x2357, 0x0100, 0xff, 0xff, 0xff),

But no 0x0109. Note this seems to be the rtl8192cu driver again.

The most straightforward way to check to see if a wifi driver has been loaded and is working for a connected device is via sudo ip link. On Raspbian, presuming there are no other wifi adapters, you'll see a wlan0 listed; if so, you are probably good to go. Otherwise, there is no chance.

You could try loading the Realtek driver the older (?) version of that TP-LINK adapter, which also looks to be the one used for the 2357:0100 based devices.

sudo modprobe 8192cu

Again, look at sudo ip link afterward -- but it is unlikely to be fruitful.

My advice with wifi adapters and linux is:

  1. Find out as much as you can first; while the USB ID won't be on the box, or even on the manufacturer's site (since they often do not make claims about what chipset is used) if you have the model number (and version...) you can probably find it online, hope it is still the same, and go from there.

  2. Buy them from a brick and mortar store that will take it back in the package without creating a fuss within 7 days. Don't say anything unless they ask, just say you want a refund or credit, if they ask say it did not work for the purpose you intended, or you ended up not needing it, etc. For little things like this most places it is not a problem.

4
  • Pardon my shoes (w and e are neighbors). I get an error that modprobe: FATAL: Module rtl8192cu not found. so i guess its not installed. Could you tell me how to install it? i'll try this one thing and if it doesn't work, return the device. I got it from amazon and actually checked that it should work, and it had several user comments mentioning the that it works out of box.I guess they got a different version or are just bluffing.
    – tejas
    Jun 15, 2016 at 15:17
  • For some reason that module seems to end up with different names on different systems -- I was writing that from a Fedora laptop. Checking a Raspian Pi it's just 8192cu (corrected above). Version 1 of the device probably does work out of the box. Mild ROTFL about the shoe/ws.
    – goldilocks
    Jun 15, 2016 at 15:22
  • Didn't work, but thanks for the help.
    – tejas
    Jun 15, 2016 at 15:26
  • I'm trying to make it work on LibreElec with no luck. On the drivers CD they provide the sources for the 8192eu but I was not able to load it although the 8192eu driver is included in LibreElec. Aug 9, 2016 at 19:27
0

I solved this issue on my linux box with kernel 4.4 using driver rtl8192eu instead rtl8192cu for WN823N v2 stick.

Here you have the driver: https://github.com/Mange/rtl8192eu-linux-driver

https://www.raspberrypi.org/forums/viewtopic.php?t=148389

Not the answer you're looking for? Browse other questions tagged or ask your own question.