3

We have one question here:

We are trying to make 3G/4G connection working on the Raspberry Pi 2, in the meantime, we also wanted to make the RPi still connecting to our local network via WiFi dongles. However we found out they can not work with each other properly.

This is what we are doing:

1- use powershell to connect Raspberry Pi 2 to a mobile network via Vodafone (Huawei) K5150 USB Mobile Broadband Modem;

2- connect Raspberry Pi 2 to our local WiFi network via Official Raspberry Pi WiFi dongle;

3- make the 3G/4G connection co-existing with LAN wireless connection.

However, we have some issues/problems here:

1- sometimes, after we plugged in the K5150 adapter, the WiFi dongle stopped working. By saying stopped working, I meant, we can not find any local WiFi networking, and we cannot connect to any. We cannot find both of them (k5150 and wifi dongle) in the device list of the default IoT App main page.

2- sometimes, we could setup the both of them (k5150 and wifi dongle) working properly. But after some time, both of them will stop working. And we cannot find them in the device list of the default IoT App main page.

So, we went ahead and did some more tests on this problem.

One of the scenarios we tested is to make the WiFi dongle working in Access Point mode while connecting the 3G/4G adapter to the mobile network. They both worked fine with each other. All packages could be passed through the Access Point without any problem.

Another scenario we tested is connecting RPi to a router(it has internet access) via Ethernet cable while keeping the 3G/4G adapter connected to mobile network. And everything works fine.

So, to us, we thought the problem could be when both 3G/4G adapter and WiFi dongle have internet access, the Windows IoT Core gets confused, so it decides to turn off one of them to make sure there is only one device currently talking to internet. However, something goes wrong, which makes Windows IoT Core turn off both of them.

Any ideas or suggestions?

Thanks,

3

Seems to be a power issue to me, did you tried to connect both dongles to a powered USB hub and then to the Pi? I think that the huawei one may be drawing to much current from the USB port and make the wifi dongle stop working.

1

We actually used a very strong power supplier to the RPi, which could provide up to 3A of current. And when they both are working, the current to RPi is around 0.7A.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.