Recently I moved home from college and once I got home I decided to setup my raspberry pi.

At the house I rented at school I had setup and given the pi its own static IP of 192.168.1.191. Worked perfectly at school. No complaints.

Once I got home and plugged it in everything seemingly worked as usual. I had a network drive attached for backups, I could SSH into the pi itself. However what I found out when I went to install some updates is it could not connect to anything that wasn't on LAN.

If you ping google.com it returns "unknown host google.com"

If you try to ping something like the Google DNS server or any other IP it returns "Destination Host Unreachable."

Things like sudo apt-get update also fail to work.

I've tried changing the static IP address, and restarting my router.

My /network/interfaces file is:

auto lo

iface lo inet loopback
iface eth0 inet static

address 192.168.1.191
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

And my resolve.conf file is

nameserver 8.8.8.8

nameserver 8.8.4.4

The Raspberry Pi is a Raspberry Pi 2 running Raspbian and it is connected via Ethernet to our router. Our ISP is AT&T U-Verse and we have the router they provided us which is a Motorola NVG589.

I'm pretty new to most things Raspberry Pi and linux. So I'm probably overlooking something fairly trivial here but any help is appreciated.

  • 1
    Maybe you should try the normative approach and see if that works: raspberrypi.stackexchange.com/q/37920/5538 If it does and you are still determined to have a static IP, at least you will know the issue is your router doesn't like that, and try and work things out from there. – goldilocks Jun 16 '16 at 18:19
  • Have you checked your router configuration to see if any other devices are already using that IP addresses? – Mohammad Ali Jun 16 '16 at 18:25
  • @goldilocks I will try that. I had bought the Pi 2 right as it came out and followed a tutorial for a static IP when I needed one. It was right before that change and I never knew of the change because ever after a previous update it continued to work. Thanks for the link. – Jem Jun 16 '16 at 21:00

Have you tried configuring the Raspi's network interface using DHCP? That should normally work, and you should be able to see what IP address and nameserver info are given by the router.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.